aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-02 06:44:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-02 07:09:31 -0300
commitd9ce34edd8686bd3bb4733dd6128333046cf8fb8 (patch)
tree101c5c9c6a609a904fbdfd1ce7ca7586c5cb8bdb /testing
parent4d623abd62527121c42c584d20e45414efb1eac0 (diff)
downloadaports-d9ce34edd8686bd3bb4733dd6128333046cf8fb8.tar.bz2
aports-d9ce34edd8686bd3bb4733dd6128333046cf8fb8.tar.xz
testing/libu2f-host: upgrade to 1.1.10
Diffstat (limited to 'testing')
-rw-r--r--testing/libu2f-host/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/testing/libu2f-host/APKBUILD b/testing/libu2f-host/APKBUILD
index aa1cfaa1ec..232c4d3b1d 100644
--- a/testing/libu2f-host/APKBUILD
+++ b/testing/libu2f-host/APKBUILD
@@ -1,37 +1,34 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=libu2f-host
-pkgver=1.1.4
-pkgrel=1
+pkgver=1.1.10
+pkgrel=0
pkgdesc="Yubico Universal 2nd Factor (U2F) Host C Library"
url="https://developers.yubico.com/libu2f-host/"
arch="all"
-license="GPL-3.0-or-later LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
makedepends="hidapi-dev json-c-dev linux-headers"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://developers.yubico.com/$pkgname/Releases/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir/$pkgname-$pkgver"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://developers.yubico.com/libu2f-host/Releases/libu2f-host-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="ed411d83b6fad734dad48e5fb6ab72d5990e91bbf73a2121d7e9008c08d3f34f9b17cf4a951a91e01f33e8fba163c260ca5c944120822992a1ee1d1050bd5249 libu2f-host-1.1.4.tar.xz"
+sha512sums="91c5bf3994f1d3c9bd144f54b14b0404d839c15bef3c318619decdf1bd37214bcff33927af78a9826ff7d0bc9907c912a0e31104ae68d3a727a8436f2a1dbf7a libu2f-host-1.1.10.tar.xz"