aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-09 16:23:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-09 16:23:46 +0000
commite6a0ea013831a4d19837f4c0ff21a08cdd4c59a5 (patch)
treefcc310e7d077c419d0a798d8e59f54fa9a4236df /testing
parent047824c4194199d8be33d1f88ef8bc9c50b79333 (diff)
downloadaports-e6a0ea013831a4d19837f4c0ff21a08cdd4c59a5.tar.bz2
aports-e6a0ea013831a4d19837f4c0ff21a08cdd4c59a5.tar.xz
testing/tarantool: fix build against curl 7.62
Diffstat (limited to 'testing')
-rw-r--r--testing/tarantool/APKBUILD9
-rw-r--r--testing/tarantool/fix-compilation-with-libcurl-7.62.0.patch46
2 files changed, 52 insertions, 3 deletions
diff --git a/testing/tarantool/APKBUILD b/testing/tarantool/APKBUILD
index de57aedfd0..dbd6d37656 100644
--- a/testing/tarantool/APKBUILD
+++ b/testing/tarantool/APKBUILD
@@ -4,7 +4,7 @@
pkgname=tarantool
pkgver=1.7.4.335
_series=${pkgver%.*}; _series=${_series%.*} # x.y
-pkgrel=5
+pkgrel=6
pkgdesc="Lua application server integrated with a database management system"
url="https://tarantool.org"
# x86, aarch64: fails to build
@@ -24,7 +24,9 @@ source="http://download.tarantool.org/tarantool/$_series/src/$pkgname-$pkgver.ta
$pkgname.initd
unbundle-dependencies.patch
tests-musl-compat.patch
- tests-libressl-compat.patch"
+ tests-libressl-compat.patch
+ fix-compilation-with-libcurl-7.62.0.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -96,4 +98,5 @@ sha512sums="c95a6900d9e9b9963bb038f28f3e47d0f8fd66159efef99b98b792cd08748481043d
fe463c4b6ab8708ea6ec17bb6a887677ae131a489d2ce299ce951790b7c134ff356bc1a4d4745878beec3600ec702944c2329a3f02645f8ab0a0eb24edb6215a tarantool.initd
b48eefdf71e20db22c4366e4573441a0d4e5f6e727fc23b2b41534e8d5cc7dc9cc08baf2bf1cf1950c7b0e211920abb4254c2d1e972ec884db25800820824f2c unbundle-dependencies.patch
f6fec037780f830eb353b184d190b5dc8b481164c9cd06991f921d70be8cababb5dba43e5af96abe6fb87fda44c5573d706f7b032bc996d33debb7811b84addb tests-musl-compat.patch
-146744f2e7265de2644c03d7beb6ce1657b63a99db9c4527cb603c915082dc1184a90e92ba39bfb946f2f8f7a2b866cc8343c7e865d4245fe704447a59cc4846 tests-libressl-compat.patch"
+146744f2e7265de2644c03d7beb6ce1657b63a99db9c4527cb603c915082dc1184a90e92ba39bfb946f2f8f7a2b866cc8343c7e865d4245fe704447a59cc4846 tests-libressl-compat.patch
+db687fee5cc6cc975d560f17abf51a6a258a964ab1322ee5d209a153d98c80263fc36f0ae8e78d480dc9f0fb68d4de1e01174d111eb21e794c89d38934b85b01 fix-compilation-with-libcurl-7.62.0.patch"
diff --git a/testing/tarantool/fix-compilation-with-libcurl-7.62.0.patch b/testing/tarantool/fix-compilation-with-libcurl-7.62.0.patch
new file mode 100644
index 0000000000..41d5cc5382
--- /dev/null
+++ b/testing/tarantool/fix-compilation-with-libcurl-7.62.0.patch
@@ -0,0 +1,46 @@
+From 02da15f7109b8bb7921eb97a751607b9dd2885b2 Mon Sep 17 00:00:00 2001
+From: Vladimir Davydov <vdavydov.dev@gmail.com>
+Date: Thu, 1 Nov 2018 13:35:24 +0300
+Subject: [PATCH] httpc: fix compilation with libcurl >= 7.62.0
+
+Starting from libcurl 7.62.0, CURL_SSL_CACERT is defined as a macro
+alias to CURLE_PEER_FAILED_VERIFICATION, see
+
+ https://github.com/curl/curl/commit/3f3b26d6feb0667714902e836af608094235fca2
+
+This breaks compilation:
+
+ httpc.c:337:7: error: duplicate case value 'CURLE_PEER_FAILED_VERIFICATION'
+ case CURLE_PEER_FAILED_VERIFICATION:
+ ^
+ httpc.c:336:7: note: previous case defined here
+ case CURLE_SSL_CACERT:
+ ^
+ curl.h:589:26: note: expanded from macro 'CURLE_SSL_CACERT'
+ #define CURLE_SSL_CACERT CURLE_PEER_FAILED_VERIFICATION
+ ^
+
+Fix this by using CURLE_SSL_CACERT only if libcurl version is less
+than 7.62.0.
+
+Note, we can't use CURL_AT_LEAST_VERSION to check libcurl version,
+because it isn't available in libcurl shipped with CentOS 6.
+---
+ src/httpc.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/httpc.c b/src/httpc.c
+index 4d48a313d8..950f8b32f6 100644
+--- a/src/httpc.c
++++ b/src/httpc.c
+@@ -333,7 +333,9 @@ httpc_execute(struct httpc_request *req, double timeout)
+ ++env->stat.http_other_responses;
+ }
+ break;
+- case CURLE_SSL_CACERT:
++#if LIBCURL_VERSION_NUM < 0x073e00
++ case CURLE_SSL_CACERT: /* deprecated in libcurl 7.62.0 */
++#endif
+ case CURLE_PEER_FAILED_VERIFICATION:
+ /* 495 SSL Certificate Error (nginx non-standard) */
+ req->status = 495;