aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authoriggy <iggy@kws1.com>2020-03-10 05:41:59 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-03-10 09:24:47 -0300
commite88471f7e665fcf3299b8fbe0438b7a6aebb6f4e (patch)
tree2d70a842ae462fc527725936c6f38a7a2e935665 /testing
parent7b75f9ab7d15988af3af605939cf9455ec46d2a9 (diff)
downloadaports-e88471f7e665fcf3299b8fbe0438b7a6aebb6f4e.tar.bz2
aports-e88471f7e665fcf3299b8fbe0438b7a6aebb6f4e.tar.xz
testing/micro: fix version number in the binary
Recent versions of micro changed where they look for version info. Update our build to match the new location.
Diffstat (limited to 'testing')
-rw-r--r--testing/micro/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/micro/APKBUILD b/testing/micro/APKBUILD
index 053a4e0907..45c4748510 100644
--- a/testing/micro/APKBUILD
+++ b/testing/micro/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=micro
pkgver=2.0.2
-pkgrel=0
+pkgrel=1
# This will need to be updated along with version as it cannot currently be
# obtained from the tarball, and is necessary if the user is to make error
# reports upsteam.
@@ -25,8 +25,12 @@ prepare() {
build() {
export GOPATH="$srcdir"
- go get -v -ldflags \
- "-s -w -X main.Version=$pkgver -X main.CommitHash=$_commithash" \
+ go get -v -ldflags "
+ -s -w
+ -X github.com/zyedidia/micro/internal/util.Version=$pkgver-alpine$pkgrel
+ -X github.com/zyedidia/micro/internal/util.CommitHash=$_commithash
+ -X github.com/zyedidia/micro/internal/util.CompileDate=$SOURCE_DATE_EPOCH
+ " \
./cmd/micro
}