aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-24 19:16:27 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-24 14:20:36 -0300
commit0e4a6868e5348d1e3a6972fafc46aa119f593b3c (patch)
tree92938c23afb405752060f957628bb4d4e29a8332 /testing
parentff962dd10244ffeaeeb5bc4e0921b251d9acc690 (diff)
downloadaports-0e4a6868e5348d1e3a6972fafc46aa119f593b3c.tar.bz2
aports-0e4a6868e5348d1e3a6972fafc46aa119f593b3c.tar.xz
testing/kolourpaint: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/kolourpaint/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/kolourpaint/APKBUILD b/testing/kolourpaint/APKBUILD
new file mode 100644
index 0000000000..22d7800604
--- /dev/null
+++ b/testing/kolourpaint/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kolourpaint
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="http://www.kolourpaint.org/"
+pkgdesc="An easy-to-use paint program"
+license="BSD-2-Clauase AND LGPL-2.0-or-later AND GFDL-1.2"
+makedepends="extra-cmake-modules qt5-qtbase-dev kdoctools-dev ki18n-dev kguiaddons-dev kwidgetsaddons-dev kio-dev kxmlgui-dev kiconthemes-dev ktextwidgets-dev kitemmodels-dev kdelibs4support-dev libksane-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="3a0b497003de467c19898682e1f0d76014ec9e68506271492fc8f30e9b9f08fa8639267c1fa84b18dde3d807d81e3db791764a6a43ac8cd7ca7d53b871410baa kolourpaint-19.04.2.tar.xz"