aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorStefan Wagner <stw@bit-strickerei.de>2018-08-12 00:55:42 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-11-04 22:30:57 +0200
commit131cd407a6fe2275042cc789466f8657babde87f (patch)
treeb7b1a56d1d56be5d02989e81f41f41f0e017671d /testing
parent3e022d27f64d7e7c2789a5f58e77b79098733b17 (diff)
downloadaports-131cd407a6fe2275042cc789466f8657babde87f.tar.bz2
aports-131cd407a6fe2275042cc789466f8657babde87f.tar.xz
testing/py-anyjson: fix python3 build
* Added patch from https://bitbucket.org/runeh/anyjson/pull-requests/7/add-support-for-python-34-35-and-36/diff
Diffstat (limited to 'testing')
-rw-r--r--testing/py-anyjson/APKBUILD22
-rw-r--r--testing/py-anyjson/python3.patch58
2 files changed, 73 insertions, 7 deletions
diff --git a/testing/py-anyjson/APKBUILD b/testing/py-anyjson/APKBUILD
index 4641a62508..2631e522b5 100644
--- a/testing/py-anyjson/APKBUILD
+++ b/testing/py-anyjson/APKBUILD
@@ -1,22 +1,31 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-anyjson
_pkgname=anyjson
pkgver=0.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Wraps the best available JSON implementation available in a common interface"
url="https://bitbucket.org/runeh/anyjson/"
arch="noarch"
license="BSD"
+checkdepends="py-future py-nose"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ python3.patch"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
}
package() {
@@ -44,6 +53,5 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="2ea28d6ec311aeeebaf993cb3008b27c anyjson-0.3.3.tar.gz"
-sha256sums="37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba anyjson-0.3.3.tar.gz"
-sha512sums="9e70df3cb8bfe2348fdb0eb03cf3c33ca5a1171aca6467787fc28c161354b5ebe89b2f73badfa00708774d6825799860493ddcac7f5da8cc9c251b92b5a343bc anyjson-0.3.3.tar.gz"
+sha512sums="9e70df3cb8bfe2348fdb0eb03cf3c33ca5a1171aca6467787fc28c161354b5ebe89b2f73badfa00708774d6825799860493ddcac7f5da8cc9c251b92b5a343bc anyjson-0.3.3.tar.gz
+d8e70ed13971e78a6f225df7fec74813a3c565446c1c538ac35f91a1e752a4381d895c87994d848c3661c736811b05b70084e3b8c5e3d6531e8424979b48cfb6 python3.patch"
diff --git a/testing/py-anyjson/python3.patch b/testing/py-anyjson/python3.patch
new file mode 100644
index 0000000000..ce84c05eed
--- /dev/null
+++ b/testing/py-anyjson/python3.patch
@@ -0,0 +1,58 @@
+diff -ur a/anyjson/__init__.py b/anyjson/__init__.py
+--- a/anyjson/__init__.py 2018-11-03 12:48:31.808085115 +0100
++++ b/anyjson/__init__.py 2018-11-03 12:48:39.784931829 +0100
+@@ -1,7 +1,10 @@
+ """Wraps the best available JSON implementation available in a common
+ interface"""
+
++from __future__ import print_function
+ import sys
++from future.utils import raise_with_traceback
++from past.builtins import basestring
+
+ VERSION = (0, 3, 3)
+ __version__ = ".".join(map(str, VERSION[0:3])) + "".join(VERSION[3:])
+@@ -85,8 +88,8 @@
+ TypeError if the object could not be serialized."""
+ try:
+ return self._encode(data)
+- except self._encode_error, exc:
+- raise TypeError, TypeError(*exc.args), sys.exc_info()[2]
++ except self._encode_error as exc:
++ raise_with_traceback(TypeError(*exc.args))
+ serialize = dumps
+
+ def loads(self, s):
+@@ -97,8 +100,8 @@
+ if self._filedecode and not isinstance(s, basestring):
+ return self._filedecode(StringIO(s))
+ return self._decode(s)
+- except self._decode_error, exc:
+- raise ValueError, ValueError(*exc.args), sys.exc_info()[2]
++ except self._decode_error as exc:
++ raise_with_traceback(ValueError(*exc.args))
+ deserialize = loads
+
+
+@@ -117,7 +120,7 @@
+ # We do NOT try to load a compatible module because that may throw an
+ # exception, which renders the package uninstallable with easy_install
+ # (It trys to execfile the script when installing, to make sure it works)
+- print "Running anyjson as a stand alone script is not supported"
++ print("Running anyjson as a stand alone script is not supported")
+ sys.exit(1)
+ else:
+ for modspec in _modules:
+diff -ur a/setup.py b/setup.py
+--- a/setup.py 2018-11-03 12:48:31.808085115 +0100
++++ b/setup.py 2018-11-03 12:48:47.935115786 +0100
+@@ -87,6 +87,9 @@
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
++ 'Programming Language :: Python :: 3.4',
++ 'Programming Language :: Python :: 3.5',
++ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Programming Language :: Python :: Implementation :: Jython',