aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTom Parker-Shemilt <palfrey@tevp.net>2019-11-14 15:52:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-27 07:29:16 +0000
commit2c843fd6dacfbad67368e3332b6024fae41b897c (patch)
tree7f487cc44b81a85b7ecb5252f0b53b324be75783 /testing
parent94af33d74e484fad53f8bafc36b5ecbf29c5e792 (diff)
downloadaports-2c843fd6dacfbad67368e3332b6024fae41b897c.tar.bz2
aports-2c843fd6dacfbad67368e3332b6024fae41b897c.tar.xz
Stop using ftp://ftp.gnu.org and http://ftp.gnu.org in favour of the HTTPS variant
Diffstat (limited to 'testing')
-rw-r--r--testing/binutils-cross-embedded/APKBUILD2
-rw-r--r--testing/enscript/APKBUILD2
-rw-r--r--testing/gforth/APKBUILD2
-rw-r--r--testing/libosip2/APKBUILD2
-rw-r--r--testing/octave/APKBUILD2
-rw-r--r--testing/snapper/musl-mktime.patch2
-rw-r--r--testing/uucp/APKBUILD2
-rw-r--r--testing/vcdimager/APKBUILD2
-rw-r--r--testing/zile/APKBUILD2
9 files changed, 9 insertions, 9 deletions
diff --git a/testing/binutils-cross-embedded/APKBUILD b/testing/binutils-cross-embedded/APKBUILD
index 79a3ebcac1..ad087584f1 100644
--- a/testing/binutils-cross-embedded/APKBUILD
+++ b/testing/binutils-cross-embedded/APKBUILD
@@ -18,7 +18,7 @@ for target in $_targets; do
targetnorm="${target//-/_}"
subpackages="$_pkgbase-$target:$targetnorm $subpackages"
done
-source="http://ftp.gnu.org/gnu/$_pkgbase/$_pkgbase-$pkgver.tar.bz2"
+source="https://ftp.gnu.org/gnu/$_pkgbase/$_pkgbase-$pkgver.tar.bz2"
builddir="$srcdir/$_pkgbase-$pkgver"
diff --git a/testing/enscript/APKBUILD b/testing/enscript/APKBUILD
index ac79e342e1..e357371e5a 100644
--- a/testing/enscript/APKBUILD
+++ b/testing/enscript/APKBUILD
@@ -7,7 +7,7 @@ url="https://www.gnu.org/software/enscript/"
arch="all"
license="GPL-3.0-only"
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/gnu/enscript/$pkgname-$pkgver.tar.gz"
+source="https://ftp.gnu.org/gnu/enscript/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
options="!check"
diff --git a/testing/gforth/APKBUILD b/testing/gforth/APKBUILD
index 4854545db7..b6cff3e362 100644
--- a/testing/gforth/APKBUILD
+++ b/testing/gforth/APKBUILD
@@ -10,7 +10,7 @@ license="GPL-3.0-or-later"
options="!check" # Hangs
makedepends="libffi-dev libtool m4"
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/gnu/gforth/$pkgname-$pkgver.tar.gz"
+source="https://ftp.gnu.org/gnu/gforth/$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
diff --git a/testing/libosip2/APKBUILD b/testing/libosip2/APKBUILD
index 96f17aa53b..a43fe9685c 100644
--- a/testing/libosip2/APKBUILD
+++ b/testing/libosip2/APKBUILD
@@ -10,7 +10,7 @@ license="LGPL-2.1-or-later"
makedepends="autoconf automake libtool"
options="libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.gnu.org/gnu/osip/libosip2-$pkgver.tar.gz"
+source="https://ftp.gnu.org/gnu/osip/libosip2-$pkgver.tar.gz"
prepare() {
default_prepare
diff --git a/testing/octave/APKBUILD b/testing/octave/APKBUILD
index 639afae8c9..0eb0ff8295 100644
--- a/testing/octave/APKBUILD
+++ b/testing/octave/APKBUILD
@@ -12,7 +12,7 @@ makedepends="autoconf automake libtool bison curl fftw-dev fltk-dev fontconfig-d
freetype-dev gfortran glu-dev gnuplot imagemagick-dev hdf5-dev
lapack-dev libsm-dev libltdl lcms2-dev pcre-dev perl pkgconf qt5-qtbase-dev
readline-dev texinfo zlib-dev texlive texlive-dvi"
-source="ftp://ftp.gnu.org/gnu/octave/$pkgname-$pkgver.tar.gz
+source="https://ftp.gnu.org/gnu/octave/$pkgname-$pkgver.tar.gz
libinterp-deps.patch
abs.patch
"
diff --git a/testing/snapper/musl-mktime.patch b/testing/snapper/musl-mktime.patch
index 22cbff4888..b4351f4fc8 100644
--- a/testing/snapper/musl-mktime.patch
+++ b/testing/snapper/musl-mktime.patch
@@ -1,4 +1,4 @@
-According to http://ftp.gnu.org/old-gnu/Manuals/glibc-2.2.3/html_chapter/libc_21.html
+According to https://ftp.gnu.org/old-gnu/Manuals/glibc-2.2.3/html_chapter/libc_21.html
timelocal(2) is functionally identical to mktime(2), but more
mnemonically named. There is no timelocal(2) defined in musl libc.
diff --git a/testing/uucp/APKBUILD b/testing/uucp/APKBUILD
index f5e04333ae..0c8470b170 100644
--- a/testing/uucp/APKBUILD
+++ b/testing/uucp/APKBUILD
@@ -16,7 +16,7 @@ subpackages="$pkgname-doc"
options="suid"
pkgusers="uucp"
pkggroups="uucp"
-source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
diff --git a/testing/vcdimager/APKBUILD b/testing/vcdimager/APKBUILD
index 72890c7e8d..19fc7b43e0 100644
--- a/testing/vcdimager/APKBUILD
+++ b/testing/vcdimager/APKBUILD
@@ -10,7 +10,7 @@ license="GPL"
options="!check"
makedepends="libxml2-dev libcdio-dev popt-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source=""ftp://ftp.gnu.org/gnu/vcdimager/${pkgname}-${pkgver}.tar.gz
+source="https://ftp.gnu.org/gnu/vcdimager/${pkgname}-${pkgver}.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
diff --git a/testing/zile/APKBUILD b/testing/zile/APKBUILD
index ce5a25a88f..5999a9319d 100644
--- a/testing/zile/APKBUILD
+++ b/testing/zile/APKBUILD
@@ -11,7 +11,7 @@ depends=""
makedepends="ncurses-dev gc-dev perl help2man"
install=""
subpackages="${pkgname}-doc"
-source="http://ftp.gnu.org/gnu/zile/${pkgname}-${pkgver}.tar.gz"
+source="https://ftp.gnu.org/gnu/zile/${pkgname}-${pkgver}.tar.gz"
builddir="$srcdir/${pkgname}-${pkgver}"
build() {