aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-15 17:43:23 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-09-17 07:13:59 +0000
commit324e59c2abb283c5c0c5c946419a34d7ea9b9cba (patch)
tree68e41edfa89da01718e61ef16206ac2dd38d34ef /testing
parent5c547c54a6e77fe662e956275c9af234c3fa024a (diff)
downloadaports-324e59c2abb283c5c0c5c946419a34d7ea9b9cba.tar.bz2
aports-324e59c2abb283c5c0c5c946419a34d7ea9b9cba.tar.xz
testing/ipython: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/ipython/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/ipython/APKBUILD b/testing/ipython/APKBUILD
new file mode 100644
index 0000000000..0ec7802729
--- /dev/null
+++ b/testing/ipython/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=ipython
+pkgver=6.5.0
+pkgrel=0
+pkgdesc="A rich toolkit to help you make the most of using Python interactively"
+url="https://ipython.org/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ py3-traitlets
+ py3-pexpect
+ py3-prompt_toolkit<2.0
+ py3-jedi
+ py3-pygments
+ py3-pickleshare
+ py3-decorator
+ py3-backcall
+ py3-simplegeneric
+ py3-setuptools
+ "
+checkdepends="py-pathlib2"
+makedepends="python3-dev py-setuptools"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver/"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a6f19a1e1a5c11ad84071e1b1fb20e2617a4d6b713888057d4cffbb1b076cf5472068809d7091bbd7e475e23373a249f029ea376ec10d93c9cf9a3782369b152 ipython-6.5.0.tar.gz"