aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-02-05 16:39:28 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-02-05 16:36:43 +0100
commit384c8050bfc1c043cabd80310ad8074dcaa1cdc2 (patch)
tree37bfd387d622aaff826ee61614cfb2ba8e11e9e7 /testing
parentabd86a4eb9d4fadb430daaa1e19fa5c10abdcf63 (diff)
downloadaports-384c8050bfc1c043cabd80310ad8074dcaa1cdc2.tar.bz2
aports-384c8050bfc1c043cabd80310ad8074dcaa1cdc2.tar.xz
testing/kea-hook-userchk-ldap: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/kea-hook-userchk-ldap/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/kea-hook-userchk-ldap/APKBUILD b/testing/kea-hook-userchk-ldap/APKBUILD
new file mode 100644
index 0000000000..09ca21267a
--- /dev/null
+++ b/testing/kea-hook-userchk-ldap/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=kea-hook-userchk-ldap
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Kea DHCP hook for checking user access in LDAP"
+url="https://github.com/cvut/kea-hook-userchk-ldap/"
+arch="all"
+license="MPL-2.0"
+makedepends="autoconf automake kea-dev libtool openldap-dev boost-dev log4cplus-dev"
+source="https://github.com/cvut/kea-hook-userchk-ldap/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # no tests provided
+
+prepare() {
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-generate-messages \
+ --disable-static
+ make
+}
+
+package() {
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="917a85de814c263fc794d48595c616d97d8e61d70dfd80a0f44379515fc1f0d72734d30e6de7b833f046c5842b87946e57d7c068814f7154ed210f2ceb4efb58 kea-hook-userchk-ldap-0.1.0.tar.gz"