aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-07-26 10:23:06 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-26 19:04:35 -0300
commit3ab7b6e36321ae00eaf4ef4d591f1224f398b8a0 (patch)
tree13373bce5ade82b667c15b8f80ba343acc138f0f /testing
parent6804ed7808556b9b3dbc7b38204b6bde275d1d41 (diff)
downloadaports-3ab7b6e36321ae00eaf4ef4d591f1224f398b8a0.tar.bz2
aports-3ab7b6e36321ae00eaf4ef4d591f1224f398b8a0.tar.xz
testing/py3-yoyo-migrations: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-yoyo-migrations/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-yoyo-migrations/APKBUILD b/testing/py3-yoyo-migrations/APKBUILD
new file mode 100644
index 0000000000..354175e0ef
--- /dev/null
+++ b/testing/py3-yoyo-migrations/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-yoyo-migrations
+pkgver=6.1.0
+pkgrel=0
+pkgdesc="Database migrations with SQL"
+url="https://ollycope.com/software/yoyo/latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="py3-text-unidecode py3-iniherit"
+makedepends="python3-dev py3-setuptools"
+options="!check" # no tests in pypi tarballs
+source="https://pypi.io/packages/source/y/yoyo-migrations/yoyo-migrations-$pkgver.tar.gz"
+builddir="$srcdir/yoyo-migrations-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8ac045b11cae3d68013457f1fa90a3acfdcb2055c779f56e2deb4fea42920d5e9aa9d8c3c31b22d9d1d6aa702b5ae937b6216fefce2b71f53b7994c92d64a325 yoyo-migrations-6.1.0.tar.gz"