aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-02-24 11:33:56 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 18:00:21 -0300
commit49fbe56b0a52ef1f3117688f45096b53433ca235 (patch)
tree11e89f704516ec4b7909a2305350e1486f391c9d /testing
parent48d608564cc17601a290e7a27dc3e85bacb08eae (diff)
downloadaports-49fbe56b0a52ef1f3117688f45096b53433ca235.tar.bz2
aports-49fbe56b0a52ef1f3117688f45096b53433ca235.tar.xz
testing/snapper: upgrade to 0.8.9
Diffstat (limited to 'testing')
-rw-r--r--testing/snapper/APKBUILD48
-rw-r--r--testing/snapper/fix-poll_h.patch13
-rw-r--r--testing/snapper/musl-__isleap.patch19
-rw-r--r--testing/snapper/musl-_nl_msg_cat_cntr.patch26
-rw-r--r--testing/snapper/musl-mode_t.patch12
-rw-r--r--testing/snapper/musl-stdout_stderr.patch2
-rw-r--r--testing/snapper/musl-types.patch13
-rw-r--r--testing/snapper/musl-u_int_type.patch19
-rw-r--r--testing/snapper/remove-systemd.patch33
9 files changed, 70 insertions, 115 deletions
diff --git a/testing/snapper/APKBUILD b/testing/snapper/APKBUILD
index 3983ebc50f..ed545b99c7 100644
--- a/testing/snapper/APKBUILD
+++ b/testing/snapper/APKBUILD
@@ -1,32 +1,27 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=snapper
-pkgver=0.8.5
-pkgrel=1
+pkgver=0.8.9
+pkgrel=0
pkgdesc="Manage filesystem snapshots and allow undo of system modifications"
-url="https://snapper.io"
-arch="all !armhf !armv7" # armhf: fails to build
-license="GPL-2.0"
-# 3 tests are failing
-options="!check"
+url="http://snapper.io"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" # 5 tests failing - https://github.com/openSUSE/snapper/issues/526
depends="dbus"
-makedepends="automake autoconf libtool bash
- btrfs-progs-dev e2fsprogs-dev dbus-dev acl-dev
- lvm2-dev libxml2-dev boost-dev bsd-compat-headers
- boost-thread gettext-dev libxslt docbook-xsl"
+makedepends="acl-dev autoconf automake bash boost-dev
+ boost-thread bsd-compat-headers btrfs-progs-dev
+ dbus-dev docbook-xsl e2fsprogs-dev gettext-dev
+ libtool libxml2-dev libxslt lvm2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/snapper/archive/v$pkgver.tar.gz
musl-posix.patch
- musl-mode_t.patch
musl-mktime.patch
musl-stdout_stderr.patch
musl-_nl_msg_cat_cntr.patch
- musl-__isleap.patch
- musl-types.patch
+ musl-u_int_type.patch
remove-systemd.patch
- fix-poll_h.patch"
-
-builddir="$srcdir/$pkgname-$pkgver"
+ "
prepare() {
default_prepare
@@ -41,7 +36,6 @@ prepare() {
}
build() {
- cd "$builddir"
export LDFLAGS="$LDFLAGS -lintl"
./configure \
--build=$CBUILD \
@@ -52,29 +46,25 @@ build() {
--with-conf=/etc/conf.d \
--disable-pam \
--disable-zypp \
- --disable-ext4
+ --disable-ext4 \
+ --disable-systemd
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 data/sysconfig.snapper "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="1575d3443f816f888822f929f26b124cca7e4f67bf48171dd9345e3ebaf6c72599c8056464cbc38473649c312df97264d398689bea90bc86bfa147082f6463b4 snapper-0.8.5.tar.gz
+sha512sums="5a3e45839cd4b5e621425df2e1214ca5014a391d17b489fdf7d315e8ac9959741c1f6fcf7adf644276ed11488bc0f88fcfa563198bd78824867d267df204659d snapper-0.8.9.tar.gz
a9eec8105e94c4eb097aa293754b0de45420a297ad845933a7be66b3ff49af409dd427e9bd1de569c49982c619211d1e90183ed8bf8550acb0fa9d83176e22bf musl-posix.patch
-ddcd279f77007fe905df27b904dc84c8c2eebf0cf42c9f992fdc992e2912ddaab59712c13a798243c4f81727c04ef8e0993773686ab0c682e41726a2bcad962b musl-mode_t.patch
ca59aaa4411abf51136b25ee8dd57fae6fc01ce21c36ac79811b4ed8b4352c5b396ce42b7c4c49d8679a9bef8375fe48b65c1ff84bbf1f192583f3b93dce1bd8 musl-mktime.patch
-ed393b476a679ebc8f130e34826958a30aa98dc7ac77c0c324a486cc3ed8539584552a305e2ddcb810626c6ab3478e634c77762395e2560abc935cd18e882beb musl-stdout_stderr.patch
-d5305df362df7db3b882cb491d32d11f479d1d56b21a39bc5e0cbdf7cdf70341eb566e7374bb9acc6d4fa1db027d4f009857fed21ef48ed311efaaa1be7b6329 musl-_nl_msg_cat_cntr.patch
-8278c469def65e58cb2aee039882d1d237b4b404386472f9540da11a1d3cddd60dda08a99074f9f418b328ce2c4ac73d3190a74a6fe3e00eab9adb4fed87a4ec musl-__isleap.patch
-8bc2b42bbee927ce88f77e71a9594da3b6e54e92008e5603c6d8db35b3ec37add456bcc52d7d6a913c69a395c73bd3f6a3934ea549d4cc0097cb65613f61ed48 musl-types.patch
-61401ac8e91b838231e018490af61e7fe8c954750eaff4a9ff4e435aea78531cfa2882e354cb088a3a43951d869bdf7c516969a437195362f700e655878bcd71 remove-systemd.patch
-2730b5d3d627e5d6140df1509a4676e4a8429f73a12804b88f0ef7dab46097f35ac209f3456bb0094a09843ebb810887a6392c3a6a308d27f43f2ea9621e586d fix-poll_h.patch"
+5baf722996706146b62fd0a0d9b321496fb122e700af2d3dfd8272de2678f29c79bc2b1a03634b04aab3f226632dfdebc5674d3128737e85bcc71461e951d95b musl-stdout_stderr.patch
+6f3324700cc697b29b2fe14e42eb765b4474bf7e582d8ea53122fe66e128d17584489c8e2adbfecc8aac37c683a9d4dc2a821e3ea0143334cd8b899164ba708c musl-_nl_msg_cat_cntr.patch
+36bc62b09f1795c955de603e6faa92b640b772182f00e1c192edada9b327a7433a6541d62f2d77cf1c1c0f42958409d66f987f03db75a1140b0d17b77f666bc8 musl-u_int_type.patch
+4c843d204c5da81686d5b8b99708ec73dd504969cbd9189feeb3f69db95f15b96d242c010ad48afa7d5ca76ecbe3a0c806bc1af9ffb70a7945201fd12f3b3d3b remove-systemd.patch"
diff --git a/testing/snapper/fix-poll_h.patch b/testing/snapper/fix-poll_h.patch
deleted file mode 100644
index 74de79892a..0000000000
--- a/testing/snapper/fix-poll_h.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-The correct location is <poll.h>, not <sys/poll.h>
-
---- a/snapper/SystemCmd.h 2014-02-05 14:22:06.000000000 +0100
-+++ b/snapper/SystemCmd.h 2015-08-30 10:56:03.685179465 +0200
-@@ -23,7 +23,7 @@
- #ifndef SNAPPER_SYSTEM_CMD_H
- #define SNAPPER_SYSTEM_CMD_H
-
--#include <sys/poll.h>
-+#include <poll.h>
- #include <stdio.h>
-
- #include <string>
diff --git a/testing/snapper/musl-__isleap.patch b/testing/snapper/musl-__isleap.patch
deleted file mode 100644
index 5997247cf1..0000000000
--- a/testing/snapper/musl-__isleap.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-The macro __isleap() is defined in glibc's time.h
-If it is not defined, define it the same (for musl libc).
-
---- a/client/utils/equal-date.h 2014-12-11 18:21:17.000000000 +0100
-+++ b/client/utils/equal-date.h 2015-08-30 11:18:08.181207315 +0200
-@@ -19,6 +19,13 @@
- * find current contact information at www.novell.com.
- */
-
-+#if !defined(__isleap)
-+/* Nonzero if YEAR is a leap year (every 4 years,
-+ except every 100th isn't, and every 400th is). */
-+# define __isleap(year) \
-+ ((year) % 4 == 0 && ((year) % 100 != 0 || (year) % 400 == 0))
-+#endif
-+
-
- bool
- equal_year(const struct tm& tmp1, const struct tm& tmp2);
diff --git a/testing/snapper/musl-_nl_msg_cat_cntr.patch b/testing/snapper/musl-_nl_msg_cat_cntr.patch
index d3f71064fe..9c50becaae 100644
--- a/testing/snapper/musl-_nl_msg_cat_cntr.patch
+++ b/testing/snapper/musl-_nl_msg_cat_cntr.patch
@@ -1,10 +1,10 @@
There is no _nl_msg_cat_cntr in musl libc and optimizations
based upon its unchanged value are not possible.
---- a/snapper/Regex.cc 2014-01-29 16:48:30.000000000 +0100
-+++ b/snapper/Regex.cc 2015-08-30 11:07:34.613193993 +0200
+--- a/snapper/Regex.cc
++++ b/snapper/Regex.cc
@@ -22,7 +22,9 @@
-
+ #include <stdexcept>
#include "snapper/Regex.h"
+#if defined(__GLIBC__)
@@ -13,27 +13,17 @@ based upon its unchanged value are not possible.
namespace snapper
-@@ -34,7 +36,9 @@
- nm (cflags & REG_NOSUB ? 0 : nm)
- {
- regcomp (&rx, pattern, cflags);
-+#if defined(__GLIBC__)
- my_nl_msg_cat_cntr = _nl_msg_cat_cntr;
-+#endif
- rm = new regmatch_t[nm];
- }
-
-@@ -45,7 +49,9 @@
- nm (cflags & REG_NOSUB ? 0 : nm)
- {
- regcomp (&rx, pattern.c_str (), cflags);
+@@ -40,7 +42,9 @@
+ regerror(errcode, &rx, error, esize);
+ throw std::runtime_error(string("Regex compilation error: ") + error);
+ }
+#if defined(__GLIBC__)
my_nl_msg_cat_cntr = _nl_msg_cat_cntr;
+#endif
rm = new regmatch_t[nm];
}
-@@ -60,11 +66,15 @@
+@@ -55,11 +59,15 @@
bool
Regex::match (const string& str, int eflags) const
{
diff --git a/testing/snapper/musl-mode_t.patch b/testing/snapper/musl-mode_t.patch
deleted file mode 100644
index 3c9b6e2007..0000000000
--- a/testing/snapper/musl-mode_t.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-The mode_t type is defined in fcntl.h
-
---- a/snapper/FileUtils.h 2015-02-18 18:54:03.000000000 +0100
-+++ b/snapper/FileUtils.h 2015-08-30 10:45:43.285166420 +0200
-@@ -24,6 +24,7 @@
- #define SNAPPER_FILE_UTILS_H
-
-
-+#include <fcntl.h>
- #include <string>
- #include <vector>
- #include <functional>
diff --git a/testing/snapper/musl-stdout_stderr.patch b/testing/snapper/musl-stdout_stderr.patch
index b53a15581b..1ed34b5310 100644
--- a/testing/snapper/musl-stdout_stderr.patch
+++ b/testing/snapper/musl-stdout_stderr.patch
@@ -4,7 +4,7 @@ members without renaming them - which may be a better choice.
--- a/snapper/SystemCmd.h 2015-08-30 10:59:53.740184303 +0200
+++ b/snapper/SystemCmd.h 2015-08-30 11:02:34.229187677 +0200
-@@ -31,6 +31,8 @@
+@@ -32,6 +32,8 @@
#include <list>
#include <boost/noncopyable.hpp>
diff --git a/testing/snapper/musl-types.patch b/testing/snapper/musl-types.patch
deleted file mode 100644
index 11a7896f82..0000000000
--- a/testing/snapper/musl-types.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/snapper/Snapshot.h b/snapper/Snapshot.h
-index 776dabf..ab89fc7 100644
---- a/snapper/Snapshot.h
-+++ b/snapper/Snapshot.h
-@@ -26,6 +26,7 @@
-
-
- #include <time.h>
-+#include <sys/types.h>
- #include <string>
- #include <list>
- #include <map>
-
diff --git a/testing/snapper/musl-u_int_type.patch b/testing/snapper/musl-u_int_type.patch
new file mode 100644
index 0000000000..1be4070f8d
--- /dev/null
+++ b/testing/snapper/musl-u_int_type.patch
@@ -0,0 +1,19 @@
+From 7ddd58ee5e6b7c3a8df3086ff5a6d17d19362761 Mon Sep 17 00:00:00 2001
+From: Nathan Owens <ndowens04@gmail.com>
+Date: Wed, 18 Dec 2019 18:35:55 -0600
+Subject: [PATCH] musl-_u_int-types
+
+Signed-off-by: Nathan Owens <ndowens04@gmail.com>
+---
+--- a/client/utils/JsonFormatter.h
++++ b/client/utils/JsonFormatter.h
+@@ -25,6 +25,9 @@
+ #include <string>
+ #include <vector>
+ #include <utility>
++#ifndef __GLIBC__
++#include <sys/types.h>
++#endif
+
+ namespace snapper
+ {
diff --git a/testing/snapper/remove-systemd.patch b/testing/snapper/remove-systemd.patch
index 8f84cba64f..9751bd5f91 100644
--- a/testing/snapper/remove-systemd.patch
+++ b/testing/snapper/remove-systemd.patch
@@ -1,16 +1,29 @@
---- a/data/Makefile.am.orig
+--- a/configure.ac
+@@ -123,6 +119,10 @@ AC_ARG_ENABLE([zypp], AC_HELP_STRING([--disable-zypp],[Disable zypp plugin suppo
+ [with_zypp=$enableval],[with_zypp=yes])
+ AM_CONDITIONAL(HAVE_ZYPP, [test "x$with_zypp" = "xyes"])
+
++AC_ARG_ENABLE([systemd], AC_HELP_STRING([--disable-systemd],[Disable systemd support]),
++ [enable_systemd=$enableval],[enable_systemd=yes])
++AM_CONDITIONAL(ENABLE_SYSTEMD, [test "x$enable_systemd" = "xyes"])
++
+ AC_CHECK_LIB(btrfs, btrfs_read_and_process_send_stream)
+ AC_CHECK_HEADERS([btrfs/version.h])
+
+--- a/data/Makefile.am
+++ b/data/Makefile.am
-@@ -21,13 +21,6 @@
+@@ -21,12 +21,14 @@ install-data-local:
install -D -m 644 org.opensuse.Snapper.conf $(DESTDIR)/etc/dbus-1/system.d/org.opensuse.Snapper.conf
install -D -m 644 org.opensuse.Snapper.service $(DESTDIR)/usr/share/dbus-1/system-services/org.opensuse.Snapper.service
-- install -D -m 644 timeline.service $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.service
-- install -D -m 644 timeline.timer $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.timer
-- install -D -m 644 cleanup.service $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.service
-- install -D -m 644 cleanup.timer $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.timer
-- install -D -m 644 boot.service $(DESTDIR)/usr/lib/systemd/system/snapper-boot.service
-- install -D -m 644 boot.timer $(DESTDIR)/usr/lib/systemd/system/snapper-boot.timer
--
++if ENABLE_SYSTEMD
+ install -D -m 644 timeline.service $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.service
+ install -D -m 644 timeline.timer $(DESTDIR)/usr/lib/systemd/system/snapper-timeline.timer
+ install -D -m 644 cleanup.service $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.service
+ install -D -m 644 cleanup.timer $(DESTDIR)/usr/lib/systemd/system/snapper-cleanup.timer
+ install -D -m 644 boot.service $(DESTDIR)/usr/lib/systemd/system/snapper-boot.service
+ install -D -m 644 boot.timer $(DESTDIR)/usr/lib/systemd/system/snapper-boot.timer
++endif
+
if HAVE_ZYPP
install -D -m 644 zypp-plugin.conf $(DESTDIR)/etc/snapper/zypp-plugin.conf
- endif