aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-03-24 19:23:47 +0000
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 18:03:30 +0200
commit6cd846794377a91332385abed59c11a01efbc977 (patch)
tree881ab4cb5b6c2bb37382d0659a7e31b79c248f09 /testing
parent399f63a370f0914dcdaeb10cf6bf6ff350125dbf (diff)
downloadaports-6cd846794377a91332385abed59c11a01efbc977.tar.bz2
aports-6cd846794377a91332385abed59c11a01efbc977.tar.xz
testing/tlp: upgrade to 1.1, clarify license and fix code-style
Diffstat (limited to 'testing')
-rw-r--r--testing/tlp/APKBUILD27
-rw-r--r--[-rwxr-xr-x]testing/tlp/tlp.initd0
2 files changed, 15 insertions, 12 deletions
diff --git a/testing/tlp/APKBUILD b/testing/tlp/APKBUILD
index 4203d3a0ec..46a2e6e98d 100644
--- a/testing/tlp/APKBUILD
+++ b/testing/tlp/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Ivan Tham <pickfire@riseup.net>
pkgname=tlp
_pkgname=TLP
-pkgver=0.9
-pkgrel=1
+pkgver=1.1
+pkgrel=0
pkgdesc="Linux Advanced Power Management"
url="http://linrunner.de/en/tlp/tlp.html"
arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0+"
+options="!check" # no test suite
subpackages="$pkgname-doc $pkgname-rdw:rdw $pkgname-bash-completion:bashcomp"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/linrunner/${_pkgname}/archive/${pkgver}.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/linrunner/$_pkgname/archive/$pkgver.tar.gz
$pkgname.initd"
-builddir="$srcdir/"$_pkgname-$pkgver
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
@@ -20,7 +21,9 @@ build() {
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install-tlp
+
install -dm755 "$pkgdir"/usr/share/man/man1
install -m644 man/*.1 "$pkgdir"/usr/share/man/man1
install -dm755 "$pkgdir"/usr/share/man/man8
@@ -29,21 +32,21 @@ package() {
}
rdw() {
- depends="tlp"
pkgdesc="Linux Advanced Power Management - Radio Device Wizard"
+ depends="tlp"
cd "$builddir"
make DESTDIR="$subpkgdir" install-rdw
}
bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ pkgdesc="Bash completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share
}
-sha512sums="126d11739f2438eb9cf8c496fc7d8cecfb05b578c2ae99264ee53d9fb85dfeab59456483867f21c621d0db6793468f7b0bd77868e999801115e157e1ba383610 TLP-0.9.tar.gz
+sha512sums="3400f2b6c249fd2e1bbbc61f23e3450ff90fabb8dd74f2903ce1f0d07e7ce3d1e61b07295736138d4697235dbee9157d3f32a8d296a649c93f73e03e3555af1e tlp-1.1.tar.gz
e6de216b2540413812711b3304cdc29c8729d527080cfd747ba382db50166dd21c6c27ff467f9f2a967e92007c7a311b00e88262952c34a22f417578c66cf4e7 tlp.initd"
diff --git a/testing/tlp/tlp.initd b/testing/tlp/tlp.initd
index 05b4c3b975..05b4c3b975 100755..100644
--- a/testing/tlp/tlp.initd
+++ b/testing/tlp/tlp.initd