aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-07 21:38:57 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-07 21:45:16 +0200
commit6f67bc92d117872255ea28559a1c4cded72757d1 (patch)
tree4d1312b650041a7b46f5d56b7bffd5e8fddcb2de /testing
parent26741307e7dce9d4e1c4c7f0682fc6259f1abcca (diff)
downloadaports-6f67bc92d117872255ea28559a1c4cded72757d1.tar.bz2
aports-6f67bc92d117872255ea28559a1c4cded72757d1.tar.xz
testing/lldb: upgrade to 5.0.1
Diffstat (limited to 'testing')
-rw-r--r--testing/lldb/APKBUILD13
-rw-r--r--testing/lldb/cmake-include-ClangConfig.patch23
-rw-r--r--testing/lldb/musl-include-limits.h.patch24
3 files changed, 30 insertions, 30 deletions
diff --git a/testing/lldb/APKBUILD b/testing/lldb/APKBUILD
index 493babeabb..6a734ed6ab 100644
--- a/testing/lldb/APKBUILD
+++ b/testing/lldb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=lldb
# Note: Update together with llvm.
-pkgver=4.0.0
+pkgver=5.0.1
pkgrel=0
_vermajor=${pkgver%%.*}
pkgdesc="Next generation, high-performance debugger"
@@ -27,8 +27,9 @@ makedepends="
"
subpackages="$pkgname-dev py2-$pkgname:py2"
source="http://llvm.org/releases/$pkgver/$pkgname-$pkgver.src.tar.xz
- musl-include-limits.h.patch
- musl-include-ptrace.aarch64.patch"
+ musl-include-ptrace.aarch64.patch
+ cmake-include-ClangConfig.patch
+ "
builddir="$srcdir/$pkgname-$pkgver.src"
build() {
@@ -70,6 +71,6 @@ py2() {
python2 -m compileall -fqd /$sitedir $sitedir
}
-sha512sums="931e8c6e74b66c4ac1c56c9d067309a319aa9a9f4c72d4ed9703be3decefeb8730084ad8c3581e4e31d61cdd4074518d2ed72bacce1e689e087b2f62ad4bb2e8 lldb-4.0.0.src.tar.xz
-200b3628f091bd5c4e5de8ebd4f0f4d4746553df50db82704381ece7ae7d4d50b9766a53dd972cd04aea4ea664dbe45ca5ac23a341d436dd8366a591a0c96722 musl-include-limits.h.patch
-1613a1cb042edd430aba6b86e4971ebb01f7d2bc3f13a5a1264cb94da7612188897e9dcaaa9233be8af5c8f4bad013dd0cfb821e323cd73dfe07fe125869ccef musl-include-ptrace.aarch64.patch"
+sha512sums="ebb3c3251098cfce28ccb6a5bbc50491a16b88d1adf3c71fd38efc95482d702e1bd9e7fb11c29597304d97cc0fd88241c70ec11276426aad901e5d23f05ca53a lldb-5.0.1.src.tar.xz
+1613a1cb042edd430aba6b86e4971ebb01f7d2bc3f13a5a1264cb94da7612188897e9dcaaa9233be8af5c8f4bad013dd0cfb821e323cd73dfe07fe125869ccef musl-include-ptrace.aarch64.patch
+18ea4cd3ef357299833e243613031ad67ff82f7c93c1f3fbe2cbce8876ffeec2d8ff2f94c8242ea540c2604ffbc023fb2678643fc9d3b64231f096054d186aef cmake-include-ClangConfig.patch"
diff --git a/testing/lldb/cmake-include-ClangConfig.patch b/testing/lldb/cmake-include-ClangConfig.patch
new file mode 100644
index 0000000000..96fd332b64
--- /dev/null
+++ b/testing/lldb/cmake-include-ClangConfig.patch
@@ -0,0 +1,23 @@
+This fixes the following build error:
+
+ [869/876] Linking CXX shared library lib/liblldb.so.5.0.0
+ FAILED: lib/liblldb.so.5.0.0
+ ...
+ /usr/bin/../lib/gcc/x86_64-alpine-linux-musl/6.4.0/../../../libclangSema.a(SemaExprObjC.cpp.o): In function `applyCocoaAPICheck(clang::Sema&, clang::ObjCMessageExpr const*, unsigned int, bool (*)(clang::ObjCMessageExpr const*, clang::NSAPI const&, clang::edit::Commit&)) [clone .constprop.696]':
+ SemaExprObjC.cpp:(.text._ZL18applyCocoaAPICheckRN5clang4SemaEPKNS_15ObjCMessageExprEjPFbS4_RKNS_5NSAPIERNS_4edit6CommitEE.constprop.696+0x13c): undefined reference to `clang::edit::rewriteObjCRedundantCallWithLiteral(clang::ObjCMessageExpr const*, clang::NSAPI const&, clang::edit::Commit&)'
+ /usr/bin/../lib/gcc/x86_64-alpine-linux-musl/6.4.0/../../../libclangSema.a(SemaExprObjC.cpp.o): In function `(anonymous namespace)::ARCCastChecker::VisitCallExpr(clang::CallExpr*)':
+ SemaExprObjC.cpp:(.text._ZN12_GLOBAL__N_114ARCCastChecker13VisitCallExprEPN5clang8CallExprE+0x12e): undefined reference to `clang::ento::coreFoundation::followsCreateRule(clang::FunctionDecl const*)'
+ clang-5.0: error: linker command failed with exit code 1 (use -v to see invocation)
+
+See https://github.com/alpinelinux/aports/pull/2342 for more information.
+
+--- a/cmake/modules/LLDBStandalone.cmake
++++ b/cmake/modules/LLDBStandalone.cmake
+@@ -100,6 +100,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
+
+ # Import CMake library targets from LLVM and Clang.
+ include("${LLVM_OBJ_ROOT}/lib${LLVM_LIBDIR_SUFFIX}/cmake/llvm/LLVMConfig.cmake")
++ include("/usr/lib/cmake/clang/ClangConfig.cmake")
+ # cmake/clang/ClangConfig.cmake is not created when LLVM and Cland are built together.
+ if (EXISTS "${LLVM_OBJ_ROOT}/lib${LLVM_LIBDIR_SUFFIX}/cmake/clang/ClangConfig.cmake")
+ include("${LLVM_OBJ_ROOT}/lib${LLVM_LIBDIR_SUFFIX}/cmake/clang/ClangConfig.cmake")
diff --git a/testing/lldb/musl-include-limits.h.patch b/testing/lldb/musl-include-limits.h.patch
deleted file mode 100644
index 3cc0dd6325..0000000000
--- a/testing/lldb/musl-include-limits.h.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This patch fixes error when building with clang++:
-
- [159/862] Building CXX object source/Host/CMakeFiles/lldbHost.dir/common/FileSpec.cpp.o
- FAILED: source/Host/CMakeFiles/lldbHost.dir/common/FileSpec.cpp.o
- /usr/bin/clang++ -DHAVE_PROCESS_VM_READV -DHAVE_ROUND -DLIBXML2_DEFINED -DLLDB_DISABLE_LIBEDIT -DLLDB_USE_BUILTIN_DEMANGLER -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -Isource/Host -I../source/Host -I../include -Iinclude -I/usr/lib/llvm4/include -I/usr/include/python2.7 -I../tools/clang/include -I../clang/include -I/usr/include/libxml2 -I../source/. -I../source/Plugins/Process/Linux -I../source/Plugins/Process/POSIX -Os -fomit-frame-pointer -fPIC -fvisibility-inlines-hidden -Werror=date-time -std=c++11 -fcolor-diagnostics -ffunction-sections -fdata-sections -Wno-deprecated-declarations -Wno-unknown-pragmas -Wno-strict-aliasing -Wno-deprecated-register -Wno-vla-extension -O3 -DNDEBUG -fno-exceptions -MD -MT source/Host/CMakeFiles/lldbHost.dir/common/FileSpec.cpp.o -MF source/Host/CMakeFiles/lldbHost.dir/common/FileSpec.cpp.o.d -o source/Host/CMakeFiles/lldbHost.dir/common/FileSpec.cpp.o -c ../source/Host/common/FileSpec.cpp
- ../source/Host/common/FileSpec.cpp:92:22: error: use of undeclared identifier 'PATH_MAX'
- char resolved_path[PATH_MAX];
- ^
- ../source/Host/common/FileSpec.cpp:675:17: error: use of undeclared identifier 'PATH_MAX'
- char path_buf[PATH_MAX];
- ^
- ...
- 8 errors generated.
-
---- a/source/Host/common/FileSpec.cpp
-+++ b/source/Host/common/FileSpec.cpp
-@@ -9,6 +9,7 @@
-
- #ifndef _WIN32
- #include <dirent.h>
-+#include <limits.h>
- #else
- #include "lldb/Host/windows/windows.h"
- #endif