aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-15 08:59:19 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-15 08:59:19 +0000
commit71787c10abc67026ead59a2997e257c62de083a1 (patch)
treecc02533e0b0f909f43aae908790460857e897d0b /testing
parentc074e6e5d2c9e5d712cfbe543cf64b1b8952667f (diff)
downloadaports-71787c10abc67026ead59a2997e257c62de083a1.tar.bz2
aports-71787c10abc67026ead59a2997e257c62de083a1.tar.xz
testing/py-pluggy: move to community
Diffstat (limited to 'testing')
-rw-r--r--testing/py-pluggy/APKBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/testing/py-pluggy/APKBUILD b/testing/py-pluggy/APKBUILD
deleted file mode 100644
index 507cc56c7f..0000000000
--- a/testing/py-pluggy/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=py-pluggy
-_pkgname=${pkgname#py-*}
-pkgver=0.6.0
-pkgrel=0
-pkgdesc="Plugin management and hook calling for Python"
-url="https://pluggy.readthedocs.io/en/latest/"
-arch="noarch"
-license="MIT"
-makedepends="python2-dev python3-dev py-setuptools"
-#checkdepends="flake8 pytest py-tox"
-options="!check" # temp disable as requires tox module
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://github.com/pytest-dev/$_pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-check() {
- cd "$builddir"
- sed -i 's|envlist.*|envlist=check,py{27,36}-pytest{30}|' tox.ini
- tox
-}
-
-sha512sums="ed8fe81907c7dc476ebfbf0f7e0f902577323d64014765e7d7bfe22c2dc7e4977e1ce7ad55ce7f4e923ae23d206d6c3bcc6663de760c877fce82298cc21079db py-pluggy-0.6.0.tar.gz"