aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-22 01:24:39 +0300
committerprspkt <prspkt@protonmail.com>2019-07-22 01:24:39 +0300
commit779de61887897cdc6376e03f32272bc4a4b7a991 (patch)
treeab22daa4092e967634204935c6d47c7466cdf75d /testing
parent3173e92a7d53ff8e549628ba65593295144b9583 (diff)
downloadaports-779de61887897cdc6376e03f32272bc4a4b7a991.tar.bz2
aports-779de61887897cdc6376e03f32272bc4a4b7a991.tar.xz
testing/py3-coveralls: clarify license, modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-coveralls/APKBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/testing/py3-coveralls/APKBUILD b/testing/py3-coveralls/APKBUILD
index 4f0e4805fd..90e15be723 100644
--- a/testing/py3-coveralls/APKBUILD
+++ b/testing/py3-coveralls/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Show coverage stats online via coveralls.io"
url="https://github.com/coveralls-clients/coveralls-python"
arch="noarch"
-license="Apache-2.0"
+license="MIT"
depends="py3-coverage py3-docopt py3-requests"
makedepends="py3-setuptools"
options="!check" #no testsuite
@@ -17,12 +17,10 @@ replaces=py-coveralls # Backwards compatibility
provides=py-coveralls=$pkgver-r$pkgrel # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}