aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-17 23:28:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-18 13:55:15 -0300
commita9ef60ddceccf71e832999e4685b317e92494bbd (patch)
treedb5df62840702b4cdef2a7fed2c042c2de68fd48 /testing
parent6109c15ef62bdab1cb95bc561fa346f38720af96 (diff)
downloadaports-a9ef60ddceccf71e832999e4685b317e92494bbd.tar.bz2
aports-a9ef60ddceccf71e832999e4685b317e92494bbd.tar.xz
testing/laszip: upgrade to 3.4.1
Diffstat (limited to 'testing')
-rw-r--r--testing/laszip/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/testing/laszip/APKBUILD b/testing/laszip/APKBUILD
index 84360f6b07..698d44c1d9 100644
--- a/testing/laszip/APKBUILD
+++ b/testing/laszip/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bradley J Chambers <brad.chambers@gmail.com>
# Maintainer: Bradley J Chambers <brad.chambers@gmail.com>
pkgname=laszip
-pkgver=3.2.2
+pkgver=3.4.1
pkgrel=0
pkgdesc="LASzip point cloud compression library"
url="https://github.com/laszip/laszip"
@@ -9,24 +9,21 @@ arch="all"
license="LGPL-2.0-or-later"
options="!check"
makedepends="cmake"
-install=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/LASzip/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/LASzip-"$pkgver"
build() {
- cd "$builddir"
-
- mkdir build && cd build
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
- make
+ mkdir build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
}
package() {
cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}
-sha512sums="c4dac1fd525b1889fa8cc77f168bc3c83053619402ec13ac0ae58665cfd4440b9135ce30c4ade925a0ac9db7e3f717344859e511b2207841c84dc2453c6cf7f7 laszip-3.2.2.tar.gz"
+sha512sums="875303d4672c61778694b8a969cc1e4239564f2fa81b35cba472f7eb28c71ca9bf052ca633dcdc8cbfb486a6c6849caed9833669fd1ba0aa5ee0065e7e2013f1 laszip-3.4.1.tar.gz"