aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:52:27 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:52:27 +0000
commitbb160bb259b96da87176aa01213e1a75306069ae (patch)
tree24006feb1e93bf5de2f2247c181efba6556c442a /testing
parentbf9d181f3de29031973b61ebea07586c3139588c (diff)
downloadaports-bb160bb259b96da87176aa01213e1a75306069ae.tar.bz2
aports-bb160bb259b96da87176aa01213e1a75306069ae.tar.xz
community/py-greenlet: moved from testing, added python3 support, added py2/py3 subpackages
Diffstat (limited to 'testing')
-rw-r--r--testing/py-greenlet/APKBUILD39
-rw-r--r--testing/py-greenlet/gcc-4.8-bugfix.patch16
2 files changed, 0 insertions, 55 deletions
diff --git a/testing/py-greenlet/APKBUILD b/testing/py-greenlet/APKBUILD
deleted file mode 100644
index 8b6af4a676..0000000000
--- a/testing/py-greenlet/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Maintainer: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
-# Contributor: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
-pkgname=py-greenlet
-_pkgname=greenlet
-pkgver=0.4.10
-pkgrel=0
-pkgdesc="Lightweight in-process concurrent programming"
-url="http://pypi.python.org/pypi/greenlet"
-arch="all"
-license="MIT"
-depends=""
-makedepends="python-dev py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- env
- CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0" python setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python setup.py install --root="$pkgdir" || return 1
-}
-
-md5sums="bed0c4b3b896702131f4d5c72f87c41d greenlet-0.4.10.zip"
-sha256sums="9a98d49f63259b16d3627976b69dd856888a376c498b091c8e9ead56d5098ca8 greenlet-0.4.10.zip"
-sha512sums="7fc78b14dca079f838647fd99878850cf9e83af781c985362146a11f71c5a700fbac8148273cd1c0ec4ac6ead4cf5bd389e001b8fc1225e87e9b51919d7ecc6c greenlet-0.4.10.zip"
diff --git a/testing/py-greenlet/gcc-4.8-bugfix.patch b/testing/py-greenlet/gcc-4.8-bugfix.patch
deleted file mode 100644
index 1526f3eb18..0000000000
--- a/testing/py-greenlet/gcc-4.8-bugfix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- greenlet-0.4.0.orig/setup.py
-+++ greenlet-0.4.0/setup.py
-@@ -2,12 +2,7 @@
-
- import sys, os, glob, platform
-
--# workaround segfaults on openbsd and RHEL 3 / CentOS 3 . see
--# https://bitbucket.org/ambroff/greenlet/issue/11/segfault-on-openbsd-i386
--# https://github.com/python-greenlet/greenlet/issues/4
--if ((sys.platform == "openbsd4" and os.uname()[-1] == "i386")
-- or ("-with-redhat-3." in platform.platform() and platform.machine() == 'i686')):
-- os.environ["CFLAGS"] = ("%s %s" % (os.environ.get("CFLAGS", ""), "-Os")).lstrip()
-+os.environ['CFLAGS'] = '-O0'
-
- try:
- if not (sys.modules.get("setuptools")