aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-11-23 01:41:14 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2015-11-23 01:56:14 +0100
commite268f991adf7aca3a39f238359d73f253829b714 (patch)
treec78483ad451146bd40e5a034b1bb4ec5345111fa /testing
parentb6e8aed04b29a954dd892e5edc18b9b964db7e9a (diff)
downloadaports-e268f991adf7aca3a39f238359d73f253829b714.tar.bz2
aports-e268f991adf7aca3a39f238359d73f253829b714.tar.xz
testing/heirloom-doctools: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/heirloom-doctools/APKBUILD40
-rw-r--r--testing/heirloom-doctools/mk.config121
2 files changed, 161 insertions, 0 deletions
diff --git a/testing/heirloom-doctools/APKBUILD b/testing/heirloom-doctools/APKBUILD
new file mode 100644
index 0000000000..c9c380184f
--- /dev/null
+++ b/testing/heirloom-doctools/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=heirloom-doctools
+pkgver=150406
+pkgrel=0
+pkgdesc="The Heirloom Documentation Tools"
+url="http://n-t-roff.github.io/heirloom/doctools.html"
+arch="all"
+license="CDDL"
+depends=""
+depends_dev=""
+makedepends="flex bison"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/n-t-roff/${pkgname}/archive/${pkgver}.tar.gz
+ mk.config"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ # Copy our configuration file to the build directory.
+ cp -f "$srcdir"/mk.config "$_builddir"/ || return 1
+}
+
+build() {
+ # Unfortunately parallel build isn't supported.
+ make -j1 -C "$_builddir" || return 1
+}
+
+package() {
+ # Unfortunately parallel install isn't supported.
+ make -j1 ROOT="$pkgdir" \
+ -C "$_builddir" install || return 1
+}
+
+md5sums="c29e5ef92a9182c58a69fa26533c87ae heirloom-doctools-150406.tar.gz
+a9c5f8bc84e6d42a7c3e6264889cddf3 mk.config"
+sha256sums="d34fa5a878a4865aba929c7080e73aa97f4dd5be62801c1a85affb942d02912f heirloom-doctools-150406.tar.gz
+1442e3e1392dcdef475a660a995937fd2322646f56bf32267b89240eb4124b6b mk.config"
+sha512sums="485574e42a474e5d3b339c2bbc8daff77a3d8401792a88d7921778e6c3d9ab2d5cab75cf7f7b7b4110eadca8eb8f693da80850c4ac3a3c36df330b3405f2dc66 heirloom-doctools-150406.tar.gz
+34ba8463be83fb4dd0dde0215ddb82c12e68a7ee5cfbe5c68783f72203c066b10145787960b904f5b07b4219f62240129fb9004bdbc971d4a4c54705c85d3d4c mk.config"
diff --git a/testing/heirloom-doctools/mk.config b/testing/heirloom-doctools/mk.config
new file mode 100644
index 0000000000..9a826aec37
--- /dev/null
+++ b/testing/heirloom-doctools/mk.config
@@ -0,0 +1,121 @@
+#
+# A BSD-compatible install command.
+#
+INSTALL=/usr/bin/install
+
+#
+# Packaging prefix.
+#
+PREFIX=/usr
+
+#
+# Where to place binaries.
+#
+BINDIR=$(PREFIX)/bin/
+
+#
+# Where to place libraries.
+#
+LIBDIR=$(PREFIX)/lib
+
+#
+# Where to place ASCII charts and the like.
+#
+PUBDIR=$(PREFIX)/share/doctools
+
+#
+# Where to place manual pages.
+#
+MANDIR=$(PREFIX)/share/man
+
+#
+# Where to place the troff macro packages.
+#
+MACDIR=$(PUBDIR)/tmac
+
+#
+# Where to place the troff font files.
+#
+FNTDIR=$(PUBDIR)/font
+
+#
+# Where to place PostScript helper files.
+#
+PSTDIR=$(PUBDIR)/postscript
+
+#
+# Where to place the nroff terminal description files.
+#
+TABDIR=$(PUBDIR)/nterm
+
+#
+# Where to place troff hyphenation files.
+#
+HYPDIR=$(PUBDIR)/hyphen
+
+#
+# Where to place files belonging to the "refer" utility.
+#
+REFDIR=$(PUBDIR)/reftools
+
+#
+# Define this if you want troff and nroff to be able to process
+# locale-specific (8-bit) characters. It requires appropriate support
+# from the C library, so it does not work e.g. with diet libc.
+#
+EUC=-DEUC
+
+#
+# Binaries are stripped with this command after installation.
+#
+STRIP=strip
+
+#
+# The C compiler.
+#
+CC?=cc
+
+#
+# The C++ compiler.
+#
+CCC?=c++
+
+#
+# Compiler flags.
+#
+#CFLAGS=-O
+
+#
+# C preprocessor flags.
+#
+# Use -D_GNU_SOURCE for Linux with GNU libc.
+# Use -D_INCLUDE__STDC_A1_SOURCE for HP-UX.
+#
+CPPFLAGS+=-D_GNU_SOURCE
+
+#
+# Warning flags for the compiler.
+#
+#WARN=
+
+#
+# Linker flags.
+#
+#LDFLAGS=
+
+#
+# Additional libraries to link with.
+#
+LIBS=
+
+#
+# A Bourne-compatible shell.
+#
+SHELL=/bin/sh
+
+#
+# Run ranlib if it is in the current path. This should take care
+# of most situations. On Mac OS X, you need to uncomment "ranlib -c".
+#
+RANLIB=(hash ranlib) >/dev/null 2>&1 || exit 0; ranlib
+#RANLIB=ranlib -c