aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-05 22:37:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-06 07:07:25 -0300
commite3f73e863eeaa1e94183bcc658bf66c6eb45d354 (patch)
treeaba370ca35867d7d0ea58a4287ef099c749205cc /testing
parenta5b705703bfff685baeb2202f555c9dc795a01e5 (diff)
downloadaports-e3f73e863eeaa1e94183bcc658bf66c6eb45d354.tar.bz2
aports-e3f73e863eeaa1e94183bcc658bf66c6eb45d354.tar.xz
testing/wpa_actiond: cleanup
- Use supervise-daemon for running wpa_actiond - Fix license - Fix linting issues
Diffstat (limited to 'testing')
-rw-r--r--testing/wpa_actiond/APKBUILD21
-rw-r--r--testing/wpa_actiond/wpa_actiond.initd26
2 files changed, 17 insertions, 30 deletions
diff --git a/testing/wpa_actiond/APKBUILD b/testing/wpa_actiond/APKBUILD
index 2fafb399d1..d6d0d700cb 100644
--- a/testing/wpa_actiond/APKBUILD
+++ b/testing/wpa_actiond/APKBUILD
@@ -2,28 +2,23 @@
# Maintainer: Marian <marian.buschsieweke@ovgu.de>
pkgname=wpa_actiond
pkgver=1.4
-pkgrel=2
+pkgrel=3
pkgdesc="Daemon that connects to wpa_supplicant and handles connect and disconnect events"
url="https://git.archlinux.org/wpa_actiond.git/"
arch="all"
-license="GPL-2.0"
-depends=""
-makedepends=""
-subpackages=""
-source="https://git.archlinux.org/${pkgname}.git/snapshot/${pkgname}-${pkgver}.tar.xz
- no_trampoline.patch
- wpa_actiond.confd
- wpa_actiond.initd"
+license="GPL-2.0-only"
+source="https://git.archlinux.org/wpa_actiond.git/snapshot/wpa_actiond-$pkgver.tar.xz
+ no_trampoline.patch
+ wpa_actiond.confd
+ wpa_actiond.initd
+ "
options="!check"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
make
}
package() {
- cd "$builddir"
install -Dm755 wpa_actiond "$pkgdir"/usr/sbin/wpa_actiond
install -Dm755 ../wpa_actiond.initd "$pkgdir"/etc/init.d/wpa_actiond
install -Dm755 ../wpa_actiond.confd "$pkgdir"/etc/conf.d/wpa_actiond
@@ -32,4 +27,4 @@ package() {
sha512sums="1ac38cdb6ce534cb14cfada4def31c17feff61408868ffd63cd1a516cdbade992719b575a96f5ab4046a1d451bfae526ccdf8eb68cfc7bdc022df3506ae07296 wpa_actiond-1.4.tar.xz
ebd49ffe1a83e08cd51d99677ce8c3f84ecdd4f3ec4a2c81a336bd87af56db0d36534003f9d7c3b34de129a3a4ef4ee4e9683f2a54729af86c946206c11cd20d no_trampoline.patch
104ffd6e04d8f69fb238428256e2bc4a8e6acd5e333fc411a72b5ae2d82f4efff6e8d4e08a282ca1a8c2ffe0b2a7fd8cd3ac222e19d6c177c721b957ef4fa5e9 wpa_actiond.confd
-8e902f2bd6bad2983e1048d18a150176b65608bd74971a72fe66cd03dba3f80893240294ffac83820fc5c46e5cb10c9267d53f60c4d2d55f7a3e45005e12fbbe wpa_actiond.initd"
+37f470728d74f0ca0d7c0c37ee8642710654f7ab3f8763d8ddb629dd096ad08adec266ba8d3dc15917fdbcd5667f302f6703909b3e86cd91c5c102c7412da788 wpa_actiond.initd"
diff --git a/testing/wpa_actiond/wpa_actiond.initd b/testing/wpa_actiond/wpa_actiond.initd
index 9861168871..cad9612508 100644
--- a/testing/wpa_actiond/wpa_actiond.initd
+++ b/testing/wpa_actiond/wpa_actiond.initd
@@ -1,22 +1,14 @@
#!/sbin/openrc-run
-depend()
-{
- need net wpa_supplicant
-}
+supervisor=supervise-daemon
-start()
-{
- ebegin "Starting wpa_actiond"
- start-stop-daemon --start --quiet --exec /usr/sbin/wpa_actiond -p /var/run/wpa_actiond.pid -- \
- -i ${WPA_ACTIOND_INTERFACE} -a ${WPA_ACTIOND_SCRIPT} ${WPA_ACTIOND_OPTS}
- eend $?
-}
+name=wpa_actiond
+description="Daemon that connects to WPA Supplicant an dhandles events"
-stop()
-{
- ebegin "Stopping wpa_actiond"
- start-stop-daemon --stop --quiet --exec /usr/sbin/wpa_actiond -p /var/run/wpa_actiond.pid
- eend $?
-}
+command=/usr/sbin/wpa_actiond
+command_args="-i $WPA_ACTIOND_INTERFACE -a $WPA_ACTIOND_SCRIPT $WPA_ACTIOND_OPTS"
+command_args_foreground="-n"
+depend(){
+ need net wpa_supplicant
+}