aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-08-18 16:26:36 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-08-18 17:26:16 +0200
commitec5e9d3fd1a0dabda172429d64ff0b84328f1786 (patch)
treec943b2377f66daff0a0d073e1c88078059b7e92d /testing
parent50b0338456c21d341234ce4a9586da4f95e888b9 (diff)
downloadaports-ec5e9d3fd1a0dabda172429d64ff0b84328f1786.tar.bz2
aports-ec5e9d3fd1a0dabda172429d64ff0b84328f1786.tar.xz
testing/mtxclient: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/mtxclient/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/mtxclient/APKBUILD b/testing/mtxclient/APKBUILD
new file mode 100644
index 0000000000..8b12b9d786
--- /dev/null
+++ b/testing/mtxclient/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=mtxclient
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Client API library for Matrix, built on top of Boost.Asio"
+url="https://github.com/nheko-reborn/mtxclient"
+arch="all"
+license="MIT"
+depends_dev="nlohmann-json-dev openssl-dev zlib-dev olm-dev libsodium-dev boost-dev"
+makedepends="$depends_dev cmake gtest-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nheko-reborn/$pkgname/archive/v$pkgver.tar.gz"
+options="!check" # Requires running Synapse instance
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_LIB_EXAMPLES=OFF \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="3362e9ae44ebeb22ac036ba2ac63682eeb97248754bf4b4029ce381d6d99501a94cd82a7b2e23aefe902b4c43389ee48e5e465679ce7fbebbf4f4d06cbc19659 mtxclient-0.2.1.tar.gz"