aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-26 15:15:24 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 16:29:24 +0100
commitfa28e41d480920f6a169e292a74b31070f353615 (patch)
treef5de3e91ef8e18576bd4394203bea050b72e2027 /testing
parent9e88684d8498778006110dbaab356e0c56870ca2 (diff)
downloadaports-fa28e41d480920f6a169e292a74b31070f353615.tar.bz2
aports-fa28e41d480920f6a169e292a74b31070f353615.tar.xz
testing/libnitrokey: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libnitrokey/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/libnitrokey/APKBUILD b/testing/libnitrokey/APKBUILD
new file mode 100644
index 0000000000..74c47126dd
--- /dev/null
+++ b/testing/libnitrokey/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libnitrokey
+pkgver=3.5
+pkgrel=0
+arch="all"
+url="https://nitrokey.com/"
+pkgdesc="Communicate with Nitrokey devices in a clean and easy manner"
+license="LGPL-3.0-or-later"
+makedepends="cmake hidapi-dev"
+source="https://github.com/Nitrokey/libnitrokey/archive/v$pkgver/libnitrokey-v$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="d2a95071e92d839c8cde4ac1435158bb469c25662f2988a4e824dbc0dfe83af841e6d04589293deddd77746dbec17b30c50fab69af58cc727ed5e0f2dbd0b5e7 libnitrokey-v3.5.tar.gz"