aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-10-26 12:32:59 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-10-26 12:34:17 +0200
commite60e535e608526b765cc842022ac2f910e78961c (patch)
treec36c73aebd4cb94f64da8ab17ed5d2ad2e9f5065 /testing
parentd78c8b9cbdcab46284e5f5e91aba25203514234d (diff)
downloadaports-e60e535e608526b765cc842022ac2f910e78961c.tar.bz2
aports-e60e535e608526b765cc842022ac2f910e78961c.tar.xz
testing/duperemove: new aport
https://github.com/markfasheh/duperemove Tools for deduping file systems
Diffstat (limited to 'testing')
-rw-r--r--testing/duperemove/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/duperemove/APKBUILD b/testing/duperemove/APKBUILD
new file mode 100644
index 0000000000..bd3145f68a
--- /dev/null
+++ b/testing/duperemove/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=duperemove
+pkgver=0.11
+pkgrel=0
+pkgdesc="Tools for deduping file systems"
+url="https://github.com/markfasheh/duperemove"
+arch="all"
+license="GPL-2.0-only"
+makedepends="glib-dev linux-headers sqlite-dev"
+options="!check" # no tests provided
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/markfasheh/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="b1bc2beb92223f9b46f8838e2f983ec763a9dff302f4202a34cc5e10591b985519f0464b6eba566c56872e671ba80583c7fdf4a232325086141d011384a286cf duperemove-0.11.tar.gz"