aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-24 11:33:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-24 11:33:02 +0000
commitd20706e1d36c158ac54759032a417985b759cc1c (patch)
tree5ba3f0eaa468c15fe303c6d6b6e82499176f3a6a /testing
parent9e1b9ea181f23f6f0d290541eb847301385a4d90 (diff)
downloadaports-d20706e1d36c158ac54759032a417985b759cc1c.tar.bz2
aports-d20706e1d36c158ac54759032a417985b759cc1c.tar.xz
main/py-xml: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/py-xml/APKBUILD27
-rw-r--r--testing/py-xml/fix-python2.6.patch28
2 files changed, 0 insertions, 55 deletions
diff --git a/testing/py-xml/APKBUILD b/testing/py-xml/APKBUILD
deleted file mode 100644
index 1dd549da07..0000000000
--- a/testing/py-xml/APKBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=py-xml
-pkgver=0.8.4
-pkgrel=0
-pkgdesc="Python XML parsing library."
-url="http://pyxml.sourceforge.net/"
-license="custom"
-depends=
-makedepends="python-dev"
-source="http://downloads.sourceforge.net/sourceforge/pyxml/PyXML-$pkgver.tar.gz
- fix-python2.6.patch"
-
-_builddir="$srcdir"/PyXML-$pkgver
-build() {
- cd "$_builddir"
- patch -Np1 -i "$srcdir/fix-python2.6.patch" || return 1
- python setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python setup.py install --prefix=/usr --root="$pkgdir" || return 1
- install -D -m644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" || return 1
-}
-
-md5sums="1f7655050cebbb664db976405fdba209 PyXML-0.8.4.tar.gz
-4b652e0c866e3cca7e2386e8e383d5ba fix-python2.6.patch"
diff --git a/testing/py-xml/fix-python2.6.patch b/testing/py-xml/fix-python2.6.patch
deleted file mode 100644
index 7bf1c46fc9..0000000000
--- a/testing/py-xml/fix-python2.6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ur a/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py b/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py
---- a/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2003-03-11 15:01:34.000000000 +0100
-+++ b/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2009-05-25 16:32:26.000000000 +0200
-@@ -24,8 +24,8 @@
- self._rel = rel
- nt = ParsedNodeTest.ParsedNodeTest('node', '')
- ppl = ParsedPredicateList.ParsedPredicateList([])
-- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-- self._step = ParsedStep.ParsedStep(as, nt, ppl)
-+ asp = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-+ self._step = ParsedStep.ParsedStep(asp, nt, ppl)
- return
-
- def evaluate(self, context):
-diff -ur a/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py b/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py
---- a/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2003-03-11 15:01:34.000000000 +0100
-+++ b/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2009-05-25 16:27:55.000000000 +0200
-@@ -28,8 +28,8 @@
- self._right = right
- nt = ParsedNodeTest.ParsedNodeTest('node','')
- ppl = ParsedPredicateList.ParsedPredicateList([])
-- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-- self._middle = ParsedStep.ParsedStep(as, nt, ppl)
-+ asp = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-+ self._middle = ParsedStep.ParsedStep(asp, nt, ppl)
-
- def evaluate(self, context):
- res = []