aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-09-28 07:53:49 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-09-28 07:54:15 +0000
commitd86eb1f2c8a3b759bed360350826821463548833 (patch)
treeca9ebc77ffe943c7a3d45795ab4aa6e1eacd4221 /testing
parent5edcfa2d670fc76bb50839832a6180c9bcd38cd3 (diff)
downloadaports-d86eb1f2c8a3b759bed360350826821463548833.tar.bz2
aports-d86eb1f2c8a3b759bed360350826821463548833.tar.xz
testing/pm-utils: new aport
A small collection of scripts that handle suspend and resume on behalf of HAL
Diffstat (limited to 'testing')
-rw-r--r--testing/pm-utils/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/pm-utils/APKBUILD b/testing/pm-utils/APKBUILD
new file mode 100644
index 0000000000..1afed83ebd
--- /dev/null
+++ b/testing/pm-utils/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=pm-utils
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="A small collection of scripts that handle suspend and resume on behalf of HAL"
+url="http://pm-utils.freedesktop.org"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://pm-utils.freedesktop.org/releases/$pkgname-$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="1742a556089c36c3a89eb1b957da5a60 pm-utils-1.4.1.tar.gz"