aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-12 19:32:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-12 19:32:25 +0000
commit98905c98d74fe87b31964df79e020eaba87c3e5f (patch)
tree0ea9e9c954d1c356b3f89e26ee0c2d4293970bef /testing
parent0ae3453479574b13451908881b854a767ddb3e8a (diff)
downloadaports-98905c98d74fe87b31964df79e020eaba87c3e5f.tar.bz2
aports-98905c98d74fe87b31964df79e020eaba87c3e5f.tar.xz
testing/gnumeric: new aport
A GNOME Spreadsheet Program http://www.gnome.org/projects/gnumeric/
Diffstat (limited to 'testing')
-rw-r--r--testing/gnumeric/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/gnumeric/APKBUILD b/testing/gnumeric/APKBUILD
new file mode 100644
index 0000000000..ef7d620a46
--- /dev/null
+++ b/testing/gnumeric/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnumeric
+pkgver=1.10.3
+pkgrel=0
+pkgdesc="A GNOME Spreadsheet Program"
+url="http://www.gnome.org/projects/gnumeric/"
+license="GPL"
+makedepends="gtk+-dev intltool desktop-file-utils libglade-dev goffice-dev
+ rarian"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.10/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-schemas-install \
+ --disable-static \
+ --enable-ssindex || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+md5sums="7da8b0acac1395c6fb049d5be7da37ef gnumeric-1.10.3.tar.bz2"