aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2010-11-24 16:32:00 +0200
committerTimo Teräs <timo.teras@iki.fi>2010-11-24 16:32:24 +0200
commitad7b8efe3011954b8c0da3f722ef117c768f3a22 (patch)
tree01d7534ea7a5c250fa485c025456ee1db8adb929 /testing
parent77b5897fc3d7f3dabe54c23a0b830dae9d6593c6 (diff)
downloadaports-ad7b8efe3011954b8c0da3f722ef117c768f3a22.tar.bz2
aports-ad7b8efe3011954b8c0da3f722ef117c768f3a22.tar.xz
testing/squark: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/squark/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/squark/APKBUILD b/testing/squark/APKBUILD
new file mode 100644
index 0000000000..ed5969525d
--- /dev/null
+++ b/testing/squark/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Timo TerÃs <timo.teras@iki.fi>
+pkgname=squark
+pkgver=0.1
+pkgrel=0
+pkgdesc="Squark - Squid User Authentication and Rating Kit"
+subpackages=
+depends="haserl lua"
+makedepends="net-snmp-dev cmph-dev lua pkgconfig"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ "
+url="http://git.alpinelinux.org/cgit/squark/"
+license=GPL-2
+
+prepare() {
+ cd "$srcdir"
+ ln -s squark-master $pkgname-$pkgver
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's:-Werror::' Make.rules
+ for i in $source; do
+ case $i in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1
+ esac
+ done
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make FULL_VERSION="$pkgver-r$pkgrel" || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make FULL_VERSION="$pkgver-r$pkgrel" DESTDIR="$pkgdir" install
+}
+
+md5sums="d7acc2d0f3a9ecff53b0b79eb6544eb6 squark-0.1.tar.bz2"