aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:22:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:41:29 +0200
commit92fe57ba231c2846b1e442b4a187db7a57ae5b8c (patch)
tree00cd7c3e7e89a188dd20d89bf3d9e9347ff1970f /testing
parent431580e26f764631d14d6f1f0fc7061a1cb7d781 (diff)
downloadaports-92fe57ba231c2846b1e442b4a187db7a57ae5b8c.tar.bz2
aports-92fe57ba231c2846b1e442b4a187db7a57ae5b8c.tar.xz
testing/ocaml-migrate-parsetree: upgrade to 1.0.11 and improve abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/ocaml-migrate-parsetree/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/testing/ocaml-migrate-parsetree/APKBUILD b/testing/ocaml-migrate-parsetree/APKBUILD
index ee26581c04..35a7aa26bc 100644
--- a/testing/ocaml-migrate-parsetree/APKBUILD
+++ b/testing/ocaml-migrate-parsetree/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-migrate-parsetree
-pkgver=1.0.9
-pkgrel=1
+pkgver=1.0.11
+pkgrel=0
pkgdesc="Convert OCaml parsetrees between different major versions"
url="https://github.com/ocaml-ppx/ocaml-migrate-parsetree"
arch="all !x86 !armhf !s390x" # limited by ocaml
@@ -39,11 +39,11 @@ package() {
find usr/lib/ocaml -name '*.cmxs' -exec chmod 0755 {} \;
# Remove annotation files, sources and some generated code (?).
- find usr/lib/ocaml \
- -name '*.cmt' -delete \
- -o -name '*.cmti' -delete \
- -o -name '*.ml' -delete \
- -o -name '*.ml-gen' -delete
+ find usr/lib/ocaml \( \
+ -name '*.cmt' -o \
+ -name '*.cmti' -o \
+ -name '*.ml' -o \
+ -name '*.ml-gen' \) -delete
# There's just a readme, changelog etc.
rm -Rf usr/doc
@@ -63,14 +63,13 @@ dev() {
depends="$depends_dev
$pkgname=$pkgver-r$pkgrel
$pkgname-ocamlbuild=$pkgver-r$pkgrel"
- local sitelib="usr/lib/ocaml/$pkgname"
cd "$pkgdir"
- local path; for path in $(find $sitelib*/ \
- -name '*.cmx' \
- -o -name '*.cmxa' \
- -o -name '*.mli')
+ local path; for path in $(find usr/lib/ocaml/$pkgname*/ \
+ -name '*.cmx' -o \
+ -name '*.cmxa' -o \
+ -name '*.mli')
do
mkdir -p "${path%/*}"
mv "$path" "$subpkgdir"/${path%/*}/
@@ -78,4 +77,4 @@ dev() {
done
}
-sha512sums="4c0591803ec11e9e4bf6c3368c8f83b532449bacc7cdcbbc466504504c7dce8a8a796bb55e46bf63ce21ee35dad15855c44931c0bacef9e79908bce9a1a49f4f ocaml-migrate-parsetree-1.0.9.tar.gz"
+sha512sums="37d877ab00e6ff6c93916da49a6bdeb0af16f4ce9cc32fe1c41438c7e344bc5a5400432f11edc44b73c8308bc509d0b393344f9d2a626677a658801655276821 ocaml-migrate-parsetree-1.0.11.tar.gz"