aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-02 21:18:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-02 21:18:19 +0200
commita52776b25f1ed6f9c8e506952681080af133a599 (patch)
tree4f9bc68f787802a2e1739d5a4b3078651d69081a /testing
parente8d72f3ef3542908701c91941b24ed9b113e6fd3 (diff)
downloadaports-a52776b25f1ed6f9c8e506952681080af133a599.tar.bz2
aports-a52776b25f1ed6f9c8e506952681080af133a599.tar.xz
community/ldap-passwd-webui: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/ldap-passwd-webui/APKBUILD40
-rw-r--r--testing/ldap-passwd-webui/ldap-passwd-webui.confd45
-rw-r--r--testing/ldap-passwd-webui/settings.patch11
3 files changed, 0 insertions, 96 deletions
diff --git a/testing/ldap-passwd-webui/APKBUILD b/testing/ldap-passwd-webui/APKBUILD
deleted file mode 100644
index 24e51fe65f..0000000000
--- a/testing/ldap-passwd-webui/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=ldap-passwd-webui
-pkgver=2.0.0
-pkgrel=0
-pkgdesc="Very simple web interface for changing password stored in LDAP or Active Directory (Samba 4 AD)"
-url="https://github.com/jirutka/ldap-passwd-webui"
-arch="noarch"
-license="MIT"
-depends="python3 py3-bottle py3-ldap3"
-makedepends="python3-dev"
-subpackages="$pkgname-waitress"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz
- $pkgname.confd
- settings.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-options="!check"
-
-package() {
- local destdir="$pkgdir/usr/share/webapps/$pkgname"
- cd "$builddir"
-
- mkdir -p "$destdir"
- cp -r static app.py index.tpl "$destdir"/
-
- install -D -m 644 settings.ini.example "$pkgdir"/etc/$pkgname.ini
-}
-
-waitress() {
- pkgdesc="Runscript for ldap-passwd-webui using Waitress WSGI server"
- depends="$pkgname=$pkgver-r$pkgrel py-waitress"
-
- mkdir -p "$subpkgdir"/etc/init.d
- ln -s waitress "$subpkgdir"/etc/init.d/$pkgname
- install -D -m 644 "$srcdir"/$pkgname.confd "$subpkgdir"/etc/conf.d/$pkgname
-}
-
-sha512sums="84ecb80ef633e9b3a04913ba0594a98e1e6372d47cdbc0330bb6f914b0b5ec84e1d2886717292d005556705eafbb74d86c85d37065feb9a9975ed393f36587b5 ldap-passwd-webui-2.0.0.tar.gz
-a1f10fbd2261e86ac249efe6571b6c42c398cd17566b602fb0a94e1c9c755da09e73ee7a1bd839181d552ffd74ea7e99352efb51b01a1a27db707e29312b8120 ldap-passwd-webui.confd
-e3200bb2495dfe0f233554c003fd2401ffdc6d86e29c1fbecb1f473f351bd4d2a97add2983d43828bed31c0afb23535cd99ff37c5d8343f304fe9edfa4ccc991 settings.patch"
diff --git a/testing/ldap-passwd-webui/ldap-passwd-webui.confd b/testing/ldap-passwd-webui/ldap-passwd-webui.confd
deleted file mode 100644
index b4bc2e91f4..0000000000
--- a/testing/ldap-passwd-webui/ldap-passwd-webui.confd
+++ /dev/null
@@ -1,45 +0,0 @@
-# Configuration for /etc/init.d/ldap-passwd-webui
-
-# User to run the application.
-#user="nobody"
-
-# Path of the configuration file.
-_cfgfile="/etc/ldap-passwd-webui.ini"
-
-# Path of the log file to catch stdout/stderr of the process.
-logfile="/var/log/$RC_SVCNAME.log"
-
-# Tell waitress to listen on an ip port combination(s).
-# Example: listen="127.0.0.1:8080 [::1]:8080 *:8181"
-listen_on="*:8080"
-
-# Path of Unix socket. If a socket path is specified, a Unix domain socket is
-# made instead of the usual inet domain socket.
-#unix_socket_path=
-
-# Octal permissions to use for the Unix domain socket. Default is 600.
-#unix_socket_perms=
-
-# Default wsgi.url_scheme value. Default is "http".
-#url_scheme=
-
-# The SCRIPT_NAME WSGI environment value.
-# Setting this to anything except the empty string will cause the WSGI
-# SCRIPT_NAME value to be the value passed minus any trailing slashes you add,
-# and it will cause the PATH_INFO of any request which is prefixed with this
-# value to be stripped of the prefix. Default is the empty string.
-#url_prefix=
-
-# Server identity used in the "Server" header in responses.
-# Default is "waitress".
-#server_ident=
-
-# Extra options for waitress-serve.
-# See https://docs.pylonsproject.org/projects/waitress/en/latest/runner.html.
-waitress_opts="--max-request-body-size=16384"
-
-
-# The following variables should not be modified!
-basedir="/usr/share/webapps/ldap-passwd-webui"
-wsgi_module="app"
-start_stop_daemon_args="--env CONF_FILE=$_cfgfile"
diff --git a/testing/ldap-passwd-webui/settings.patch b/testing/ldap-passwd-webui/settings.patch
deleted file mode 100644
index 4698faebd3..0000000000
--- a/testing/ldap-passwd-webui/settings.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/settings.ini.example
-+++ b/settings.ini.example
-@@ -12,8 +12,3 @@
- #type = ad
- #ad_domain = ad.example.org
- #search_filter = sAMAccountName={uid}
--
--[server]
--server = auto
--host = localhost
--port = 8080