aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-01-17 00:04:48 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 11:24:23 +0000
commitb87c3d6eb83ed6e575a34eed040d4e28dd286428 (patch)
tree91ec75e9d5eb6c1ae4b99919995b861d19358f5a /testing
parent1274258888a7d522f8bc6d19c7f476e2e2fd4470 (diff)
downloadaports-b87c3d6eb83ed6e575a34eed040d4e28dd286428.tar.bz2
aports-b87c3d6eb83ed6e575a34eed040d4e28dd286428.tar.xz
testing/simple-mtpfs: new aport
https://github.com/phatina/simple-mtpfs filesystem driver and CLI utility for mounting MTP based devices
Diffstat (limited to 'testing')
-rw-r--r--testing/simple-mtpfs/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/simple-mtpfs/APKBUILD b/testing/simple-mtpfs/APKBUILD
new file mode 100644
index 0000000000..0faa3ab6ea
--- /dev/null
+++ b/testing/simple-mtpfs/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=simple-mtpfs
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="filesystem driver and CLI utility for MTP based devices"
+url="https://github.com/phatina/simple-mtpfs"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="autoconf automake libmtp-dev libusb-dev fuse-dev"
+options="!check" # No test suite.
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/phatina/simple-mtpfs/archive/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/${pkgname}-${pkgname}-${pkgver}"
+
+prepare() {
+ cd "$builddir"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ ./autogen.sh
+}
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="7d2da152708c01ddd2a39c1b56cba6470bfd320b92507530cdd8fc4f25f9500ff817eac6a5d19c775f31029ae6a0baef693987c59453c60c688b84934378f772 simple-mtpfs-0.3.0.tar.gz"