aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-11-21 14:42:23 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-24 10:42:20 +0000
commitc9eb42bd96ea948f7e66fe22e0ce1753478b7f90 (patch)
tree3a1e396dda246a42853f564031fbb5dad66aad88 /testing
parent93b1a3502d9c313a27d18dec7aa75bf8a7754d94 (diff)
downloadaports-c9eb42bd96ea948f7e66fe22e0ce1753478b7f90.tar.bz2
aports-c9eb42bd96ea948f7e66fe22e0ce1753478b7f90.tar.xz
testing/py-singledispatch: new aport
New required dependency for main/py-tornado 4.3
Diffstat (limited to 'testing')
-rw-r--r--testing/py-singledispatch/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-singledispatch/APKBUILD b/testing/py-singledispatch/APKBUILD
new file mode 100644
index 0000000000..9cbf7ee7bd
--- /dev/null
+++ b/testing/py-singledispatch/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Peter Bui <pnutzh4x0r@gmail.com>
+pkgname=py-singledispatch
+_pkgname=singledispatch
+pkgver=3.4.0.3
+pkgrel=0
+pkgdesc="This library brings functools.singledispatch from Python 3.4 to Python 2.6-3.3."
+url="https://bitbucket.org/ambv/singledispatch"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev="py-setuptools"
+makedepends="python-dev $depends_dev"
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || return 1
+}
+
+md5sums="af2fc6a3d6cc5a02d0bf54d909785fcb singledispatch-3.4.0.3.tar.gz"
+sha256sums="5b06af87df13818d14f08a028e42f566640aef80805c3b50c5056b086e3c2b9c singledispatch-3.4.0.3.tar.gz"
+sha512sums="ba065d36092ddee6527be3d7cb777c51c0949855bf6dd0ffb7c25acaedaa35d36fe6dc096587acddcd1e9e54c6ac5f92c196b11f9ee1270cc0c1cf2f410446cf singledispatch-3.4.0.3.tar.gz"