aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-05-02 12:33:45 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-02 12:33:49 +0000
commite2786ac703bf4773fcfc72dde7bd11c842cb4c2f (patch)
tree037a4ceb9ba30b2d58f93a533b7d25b0e604ccff /testing
parentf6e597aa6d4288e4592bde4d957d952655ab4362 (diff)
downloadaports-e2786ac703bf4773fcfc72dde7bd11c842cb4c2f.tar.bz2
aports-e2786ac703bf4773fcfc72dde7bd11c842cb4c2f.tar.xz
testing/py3-lxc: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-lxc/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-lxc/APKBUILD b/testing/py3-lxc/APKBUILD
new file mode 100644
index 0000000000..14bd6168c8
--- /dev/null
+++ b/testing/py3-lxc/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-lxc
+_pkgname=python3-lxc
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="Python3 binding for liblxc"
+url="https://github.com/lxc/python3-lxc"
+arch="all"
+license="LGPL-2.1"
+depends="python3"
+makedepends="python3-dev lxc-dev"
+source="https://github.com/lxc/$_pkgname/archive/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e8a3841133e4033aa25e1fb3290dcf24cd396960f6295d99fefe9d2a08bdc0577e65876258e7ee3939b8a0a0da467d75b522a411143541d26144afdb1f741200 python3-lxc-3.0.1.tar.gz"