aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-22 00:53:41 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-28 17:14:49 +0000
commite3abbb410c71110220b5bdfda463aedea27781be (patch)
tree34b210f46e0bbf96c8a5626c2fb6e589ed95264e /testing
parentcd8a47b9122f15ac512c63a2873cdb0e317dc0db (diff)
downloadaports-e3abbb410c71110220b5bdfda463aedea27781be.tar.bz2
aports-e3abbb410c71110220b5bdfda463aedea27781be.tar.xz
testing/syntax-highlighting: new aport
Closes GH-7992
Diffstat (limited to 'testing')
-rw-r--r--testing/syntax-highlighting/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/syntax-highlighting/APKBUILD b/testing/syntax-highlighting/APKBUILD
new file mode 100644
index 0000000000..e7f585f65e
--- /dev/null
+++ b/testing/syntax-highlighting/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=syntax-highlighting
+pkgver=5.58.0
+pkgrel=0
+pkgdesc="Syntax highlighting engine for structured text and code"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="MIT"
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="a4b95a8ca9fcccf3fd5ea8d8a0d4a5b35712e69ce466bf28cf1f87831be6120c0bdb62b30fc14b1094cca7ad393fa8348ea1e0f13abc1a6cc742a521d4d7c350 syntax-highlighting-5.58.0.tar.xz"