aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2019-06-19 13:25:31 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-19 09:51:26 -0300
commitfc5de845008f4b15b10124f752840eee9b807374 (patch)
tree636165bdd95fed50a769e04d64c16bc4e73a6d88 /testing
parent9cb7b26cf99daee7c5a382c96980fa2fae291eed (diff)
downloadaports-fc5de845008f4b15b10124f752840eee9b807374.tar.bz2
aports-fc5de845008f4b15b10124f752840eee9b807374.tar.xz
testing/hidapi: upgrade to 0.9.0
hidapi has a new home at libusb - and 0.9.0 has been released.
Diffstat (limited to 'testing')
-rw-r--r--testing/hidapi/APKBUILD24
-rw-r--r--testing/hidapi/libusb_include_path.patch12
2 files changed, 7 insertions, 29 deletions
diff --git a/testing/hidapi/APKBUILD b/testing/hidapi/APKBUILD
index 76cb77e7f1..0cb206d379 100644
--- a/testing/hidapi/APKBUILD
+++ b/testing/hidapi/APKBUILD
@@ -1,34 +1,26 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer:
pkgname=hidapi
-pkgver=0.8.0_rc1
-_relver="$(echo "$pkgver" | sed s/_/-/)"
+pkgver=0.9.0
pkgrel=1
pkgdesc="Simple library for communicating with USB and Bluetooth HID devices"
-url="http://www.signal11.us/oss/hidapi/"
+url="https://github.com/libusb/hidapi"
arch="all"
license="custom"
-depends=""
-depends_dev=""
options="!check"
makedepends="libusb-dev libtool eudev-dev linux-headers autoconf automake"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/signal11/$pkgname/archive/$pkgname-${_relver}.tar.gz
- libusb_include_path.patch"
-builddir="$srcdir/$pkgname-$pkgname-$_relver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libusb/$pkgname/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
+
./bootstrap
}
build() {
- cd "$builddir"
- # Linker flags generated by automake are broken. It is easier to work
- # around by setting LDFLAGS env than messing with automake.
- LDFLAGS="$LDFLAGS -lusb-1.0 -ludev" ./configure \
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -39,7 +31,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
@@ -47,5 +38,4 @@ package() {
"$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="4529d74e715c47d788b533d94bf0ef35fa773240c9a59558d30c5ecc78cf46961de368f9385f5d84d378eaf8d4e941d553341e839674e562ccfcf52726620a65 hidapi-0.8.0_rc1.tar.gz
-94eabf809049d82585599787768bcfab795e400593f130c98c4fdf0db53629f251e5aaa39a7a469b6ff3d240f5b1edb1b2f099bf6034a6dcfa182dc2dae851a0 libusb_include_path.patch"
+sha512sums="d9f28d394b78daece7d2dfb946e62349a56b388b3a06241585c6fad5a4e24dc914723de6c0f12a9e51cd23fb245f6b5ac9b3721319646d5ba5912bbe0a3f9a52 hidapi-0.9.0.tar.gz"
diff --git a/testing/hidapi/libusb_include_path.patch b/testing/hidapi/libusb_include_path.patch
deleted file mode 100644
index 2615d363a8..0000000000
--- a/testing/hidapi/libusb_include_path.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rupN hidapi-hidapi-0.8.0-rc1-old/libusb/hid.c hidapi-hidapi-0.8.0-rc1/libusb/hid.c
---- hidapi-hidapi-0.8.0-rc1-old/libusb/hid.c 2019-01-23 10:46:10.388569561 +0100
-+++ hidapi-hidapi-0.8.0-rc1/libusb/hid.c 2019-01-23 10:47:09.798295989 +0100
-@@ -44,7 +44,7 @@
- #include <wchar.h>
-
- /* GNU / LibUSB */
--#include "libusb.h"
-+#include "libusb-1.0/libusb.h"
- #include "iconv.h"
-
- #include "hidapi.h"