aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-29 13:26:07 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-29 13:28:08 +0200
commit0084a008dee284d8ba727ade8303f709a5288219 (patch)
treea57df0a43578009ca3fcb96db01ebf5b109bbc1f /testing
parent13560770168c8c8f9c34df070f5dfb5473f67574 (diff)
downloadaports-0084a008dee284d8ba727ade8303f709a5288219.tar.bz2
aports-0084a008dee284d8ba727ade8303f709a5288219.tar.xz
testing/zziplib: improve abuild
Diffstat (limited to 'testing')
-rw-r--r--testing/zziplib/APKBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/testing/zziplib/APKBUILD b/testing/zziplib/APKBUILD
index 77ce928541..80c0fd5f3f 100644
--- a/testing/zziplib/APKBUILD
+++ b/testing/zziplib/APKBUILD
@@ -6,27 +6,16 @@ pkgrel=2
pkgdesc="Lightweight library to easily extract data from zip files"
url="http://zziplib.sourceforge.net"
arch="all"
-license="LGPL2+ or MPL 1.1"
+license="LGPL2+ MPL-1.1"
depends=""
depends_dev="zlib-dev"
makedepends="$depends_dev perl python"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
-source="http://downloads.sourceforge.net/zziplib/zziplib-${pkgver}.tar.bz2"
-
-_builddir="$srcdir"/zziplib-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://downloads.sourceforge.net/zziplib/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--prefix=/usr \
--disable-static \
@@ -35,8 +24,8 @@ build() {
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
}
utils() {