aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-17 00:56:18 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-16 20:03:40 -0300
commit0782fdfc9a0b7b79858ab0fc116ec145c66f8658 (patch)
tree302fd9e9b21405f3ae50291667e5ccbdcc438b1e /testing
parenta481a7f446a1e6dbaae6636677e5840bf8cecb32 (diff)
downloadaports-0782fdfc9a0b7b79858ab0fc116ec145c66f8658.tar.bz2
aports-0782fdfc9a0b7b79858ab0fc116ec145c66f8658.tar.xz
testing/kdesdk-thumbnailers: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/kdesdk-thumbnailers/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/kdesdk-thumbnailers/APKBUILD b/testing/kdesdk-thumbnailers/APKBUILD
new file mode 100644
index 0000000000..b6542e84f4
--- /dev/null
+++ b/testing/kdesdk-thumbnailers/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdesdk-thumbnailers
+pkgver=19.04.3
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/development/"
+pkgdesc="Plugins for the thumbnailing system"
+license="GPL-2.0-only OR GPL-3.0-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev ki18n-dev kio-dev gettext-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="b47e574bb12b00ab8503de4078547655d9884624c5a055d8e859cfbb0f33a9b49421918719f494402c0b132f26ceb8259acc2006662417141000df0b80c84337 kdesdk-thumbnailers-19.04.3.tar.xz"