aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-12-09 17:43:34 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-10 10:16:23 +0100
commit2befb2cb492f2ff03dd888143ffc800ca2657df9 (patch)
treec540f20e4f0bc37d0af24d1a772aa0125b91ba51 /testing
parent93252f57672dcedcf9220540bc7f48bc13e1a489 (diff)
downloadaports-2befb2cb492f2ff03dd888143ffc800ca2657df9.tar.bz2
aports-2befb2cb492f2ff03dd888143ffc800ca2657df9.tar.xz
testing/py3-requests-file: new aport
https://github.com/dashea/requests-file Transport adapter for fetching file:// URLs with the requests python library testing/
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-requests-file/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-requests-file/APKBUILD b/testing/py3-requests-file/APKBUILD
new file mode 100644
index 0000000000..6bf01cac70
--- /dev/null
+++ b/testing/py3-requests-file/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="py3-requests-file"
+_pyname="requests-file"
+pkgver="1.4.3"
+pkgrel=0
+pkgdesc="Transport adapter for fetching file:// URLs with the requests python library"
+url="https://github.com/dashea/requests-file"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+source="$_pyname-$pkgver.tar.gz::https://github.com/dashea/requests-file/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="30998998513ce9f21cdc37b9174f8236887aa2a40789f70f6fbfd7977059acad2edcf06e3db112f8ee59fdc9536174898229e926f680021232a16482d1a932b5 requests-file-1.4.3.tar.gz"