aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-12 01:10:55 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-12 01:23:11 +0100
commit3c39b21da5099c9c7f7f355cdcf9552cad498366 (patch)
tree218801be2a4cc95f805e78d6569cff8eaec51a2f /testing
parentd50797f345088f82ca791db85423ea62e14a9cb9 (diff)
downloadaports-3c39b21da5099c9c7f7f355cdcf9552cad498366.tar.bz2
aports-3c39b21da5099c9c7f7f355cdcf9552cad498366.tar.xz
testing/py3-astor: upgrade to 0.8.1
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-astor/APKBUILD10
-rw-r--r--testing/py3-astor/Fix-packaging-for-setuptools-41.4.patch97
-rw-r--r--testing/py3-astor/put-2-newlines-between-func-defs.patch25
3 files changed, 3 insertions, 129 deletions
diff --git a/testing/py3-astor/APKBUILD b/testing/py3-astor/APKBUILD
index 7feb38a8a8..527d8c193a 100644
--- a/testing/py3-astor/APKBUILD
+++ b/testing/py3-astor/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer:
pkgname=py3-astor
-pkgver=0.8
-pkgrel=2
+pkgver=0.8.1
+pkgrel=0
pkgdesc="Easy manipulation of Python source via the AST"
url="https://github.com/berkerpeksag/astor"
arch="noarch"
@@ -11,8 +11,6 @@ depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-nose"
source="$pkgname-$pkgver.tar.gz::https://github.com/berkerpeksag/astor/archive/$pkgver.tar.gz
- put-2-newlines-between-func-defs.patch
- Fix-packaging-for-setuptools-41.4.patch
"
builddir="$srcdir/astor-$pkgver"
@@ -28,6 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="ca787234f9a9caae37633be289d6e980e7b44507d74306ad7a30f017442d6cf423748ef35465b7b5d12bdb84ce4594af801de39882f4c11c732dba4dc65ab667 py3-astor-0.8.tar.gz
-a1b39b96a4f6b5bf2bd826af8ba88a84a1337f3464a3571b10a566aa0cdd5706f23e02398a4840bfa4b15f120595334441cb870721232047fa45d5ed5b0712df put-2-newlines-between-func-defs.patch
-48db3a399bccfbc8a5b8d45974c8508625dc84abd08c31f9f25a222cc5a71082d76bef86210bb13f40b539370f203d55e46e73fc5f19ca2a498b396402661229 Fix-packaging-for-setuptools-41.4.patch"
+sha512sums="8917898e284fb5e5855a05f8e3f1c8925c4128d2a87f67f0334914d4d3c54b53c4f0cadd04d632a7bcaf3438db7edf2d989b07a9576637c0dce6c16e85c60f83 py3-astor-0.8.1.tar.gz"
diff --git a/testing/py3-astor/Fix-packaging-for-setuptools-41.4.patch b/testing/py3-astor/Fix-packaging-for-setuptools-41.4.patch
deleted file mode 100644
index 63f57e407f..0000000000
--- a/testing/py3-astor/Fix-packaging-for-setuptools-41.4.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From 30059dac4eb832e58ab2109db84508b294ba366d Mon Sep 17 00:00:00 2001
-From: Jonathan Ringer <jonringer117@gmail.com>
-Date: Thu, 17 Oct 2019 16:54:16 -0700
-Subject: [PATCH] Fix packaging for setuptools>=41.4
-
----
- MANIFEST.in | 1 +
- astor/VERSION | 1 +
- astor/__init__.py | 5 ++++-
- setup.cfg | 3 ++-
- setup.py | 16 +---------------
- 5 files changed, 9 insertions(+), 17 deletions(-)
- create mode 100644 astor/VERSION
-
-diff --git a/MANIFEST.in b/MANIFEST.in
-index b12a6fe..81e72d5 100644
---- a/MANIFEST.in
-+++ b/MANIFEST.in
-@@ -1,3 +1,4 @@
- include README.rst AUTHORS LICENSE CHANGES
- include setuputils.py
-+include astor/VERSION
- recursive-include tests *.py
-diff --git a/astor/VERSION b/astor/VERSION
-new file mode 100644
-index 0000000..a3df0a6
---- /dev/null
-+++ b/astor/VERSION
-@@ -0,0 +1 @@
-+0.8.0
-diff --git a/astor/__init__.py b/astor/__init__.py
-index 3b02983..bdedaef 100644
---- a/astor/__init__.py
-+++ b/astor/__init__.py
-@@ -9,6 +9,7 @@
-
- """
-
-+import os
- import warnings
-
- from .code_gen import SourceGenerator, to_source # NOQA
-@@ -19,7 +20,9 @@
- from .op_util import symbol_data # NOQA
- from .tree_walk import TreeWalk # NOQA
-
--__version__ = '0.8.0'
-+ROOT = os.path.dirname(__file__)
-+with open(os.path.join(ROOT, 'VERSION')) as version_file:
-+ __version__ = version_file.read().strip()
-
- parse_file = code_to_ast.parse_file
-
-diff --git a/setup.cfg b/setup.cfg
-index 1baf6fc..a43634f 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -2,6 +2,7 @@
- name = astor
- description = Read/rewrite/write Python ASTs
- long_description = file:README.rst
-+version = file: astor/VERSION
- author = Patrick Maupin
- author_email = pmaupin@gmail.com
- platforms = Independent
-@@ -40,7 +41,7 @@ test_suite = nose.collector
- [options.packages.find]
- exclude = tests
-
--[wheel]
-+[bdist_wheel]
- universal = 1
-
- [build-system]
-diff --git a/setup.py b/setup.py
-index 4a111b5..6068493 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1,17 +1,3 @@
--import os
--import sys
--
- from setuptools import setup
--from setuptools.config import read_configuration
--
--from setuputils import find_version
--
--
--def here(*paths):
-- return os.path.join(os.path.dirname(__file__), *paths)
--
--config = read_configuration(here('setup.cfg'))
--config['metadata']['version'] = find_version(here('astor', '__init__.py'))
--config['options'].update(config['metadata'])
-
--setup(**config['options'])
-+setup()
diff --git a/testing/py3-astor/put-2-newlines-between-func-defs.patch b/testing/py3-astor/put-2-newlines-between-func-defs.patch
deleted file mode 100644
index 33fbe8ad9f..0000000000
--- a/testing/py3-astor/put-2-newlines-between-func-defs.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From ef8a6559641967bcadd4f1e08a2ed6dec8311542 Mon Sep 17 00:00:00 2001
-From: isidentical <batuhanosmantaskaya@gmail.com>
-Date: Mon, 2 Sep 2019 20:07:41 +0300
-Subject: [PATCH] put 2 newlines between func defs, resolves #156
-
----
- tests/test_code_gen.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/tests/test_code_gen.py b/tests/test_code_gen.py
-index 3cb7e64..c4935ae 100644
---- a/tests/test_code_gen.py
-+++ b/tests/test_code_gen.py
-@@ -171,9 +171,11 @@ def test_positional_only_arguments(self):
- def test(a, b, /, c, *, d, **kwargs):
- pass
-
-+
- def test(a=3, b=4, /, c=7):
- pass
-
-+
- def test(a, b=4, /, c=8, d=9):
- pass
- """