aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 00:41:41 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-26 17:00:17 +0000
commit421343f8aadc97b88a6c4d43324efb3716c7b8ca (patch)
tree5c2576f9e28b9f4ce2f320b58ac1ccb6d27b50cf /testing
parent92d5072e27e2e9dd6a683979f3f1f45a359bdfeb (diff)
downloadaports-421343f8aadc97b88a6c4d43324efb3716c7b8ca.tar.bz2
aports-421343f8aadc97b88a6c4d43324efb3716c7b8ca.tar.xz
testing/py-openapi-codec: modernize
Closes GH-8116
Diffstat (limited to 'testing')
-rw-r--r--testing/py-openapi-codec/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/testing/py-openapi-codec/APKBUILD b/testing/py-openapi-codec/APKBUILD
index 44921ad68a..f268fe7fe5 100644
--- a/testing/py-openapi-codec/APKBUILD
+++ b/testing/py-openapi-codec/APKBUILD
@@ -8,8 +8,8 @@ url="https://github.com/core-api/python-openapi-codec"
arch="noarch"
license="BSD-2-Clause"
depends="py-core-api"
-makedepends="python3-dev python2-dev py2-setuptools"
-checkdepends="py-coverage pytest py-core-api py-jinja2 py-pycodestyle py-pyflakes"
+makedepends="py3-setuptools py2-setuptools"
+checkdepends="py-coverage pytest py-jinja2 py-pycodestyle py-pyflakes"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-openapi-codec/archive/$pkgver.tar.gz
disable-flake8-tests-that-requires-pyflake15.patch
@@ -17,18 +17,15 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-openapi-code
builddir="$srcdir"/python-openapi-codec-$pkgver
build() {
- cd "$builddir"
python2 setup.py --quiet build
python3 setup.py --quiet build
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir"/usr/bin
}
check() {
- cd "$builddir"
python2 runtests
python3 runtests
}