aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-02 10:49:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-02 10:49:25 +0000
commit5c58bdbc965aca4a880ae4c342133ae2299485cc (patch)
treeb362e19c111dff925a4238b6b140665211cfacc3 /testing
parentbb43c39da7334dab2a35adba80e0b9c5ae33051c (diff)
downloadaports-5c58bdbc965aca4a880ae4c342133ae2299485cc.tar.bz2
aports-5c58bdbc965aca4a880ae4c342133ae2299485cc.tar.xz
main/spice: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/spice/APKBUILD63
-rw-r--r--testing/spice/cstdarg.patch10
2 files changed, 0 insertions, 73 deletions
diff --git a/testing/spice/APKBUILD b/testing/spice/APKBUILD
deleted file mode 100644
index 82c5787aac..0000000000
--- a/testing/spice/APKBUILD
+++ /dev/null
@@ -1,63 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=spice
-pkgver=0.10.0
-pkgrel=1
-pkgdesc="Implements the SPICE protocol"
-url="http://www.spice-space.org/"
-arch="all"
-license="LGPLv2+"
-depends=""
-depends_dev="spice-protocol pixman-dev celt051-dev openssl-dev"
-makedepends="$depends_dev alsa-lib-dev jpeg-dev libxrandr-dev cyrus-sasl-dev
- libxfixes-dev python-dev bash cegui06-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-server $pkgname-client"
-source="http://www.spice-space.org/download/releases/spice-$pkgver.tar.bz2
- cstdarg.patch"
-
-_builddir="$srcdir"/spice-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --enable-gui \
- || return 1
- make -C common WARN_CFLAGS='' || return 1
- make -C client WARN_CFLAGS='' || return 1
- make WARN_CFLAGS='' || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-server() {
- pkgdesc="Server library for SPICE"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*server.so.* "$subpkgdir"/usr/lib/
-}
-
-client() {
- pkgdesc="SPICE client"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/spicec "$subpkgdir"/usr/bin/
-}
-
-md5sums="d9f0b0280c9e2291623c9560e156be26 spice-0.10.0.tar.bz2
-3e61fdc18bf201a2b54b332fdbe2912e cstdarg.patch"
diff --git a/testing/spice/cstdarg.patch b/testing/spice/cstdarg.patch
deleted file mode 100644
index 7a16dc579c..0000000000
--- a/testing/spice/cstdarg.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./client/common.h.orig
-+++ ./client/common.h
-@@ -39,6 +39,7 @@
- #include <exception>
- #include <list>
- #include <string.h>
-+#include <cstdarg>
-
- #ifdef WIN32
- #ifdef __GNUC__