aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-13 18:31:15 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-18 16:38:22 +0100
commit710e2db076995d34d04f0b6dd5c6df93c17016ff (patch)
treea1e1900926f19dcea184ec77be7a2df95b3bcf1b /testing
parent22eca9199e62f08ef4413a509ef9fd86ed0051f8 (diff)
downloadaports-710e2db076995d34d04f0b6dd5c6df93c17016ff.tar.bz2
aports-710e2db076995d34d04f0b6dd5c6df93c17016ff.tar.xz
community/i3status: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/i3status/APKBUILD31
-rw-r--r--testing/i3status/no-pulseaudio.patch88
2 files changed, 0 insertions, 119 deletions
diff --git a/testing/i3status/APKBUILD b/testing/i3status/APKBUILD
deleted file mode 100644
index df310e2a81..0000000000
--- a/testing/i3status/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Contributor: k0r10n <k0r10n.dev@gmail.com>
-# Maintainer: Brian Cole <git@brianecole.com>
-pkgname=i3status
-pkgver=2.13
-pkgrel=1
-pkgdesc="Generates status bar for dzen2, xmobar or similar"
-url="https://i3.zekjur.net/i3status"
-arch="all"
-license="BSD-3-Clause"
-options="!check" # No test suite
-makedepends="alsa-lib-dev asciidoc autoconf automake confuse-dev libnl3-dev linux-headers yajl-dev xmlto"
-subpackages="$pkgname-doc"
-source="https://i3wm.org/i3status/i3status-$pkgver.tar.bz2
- no-pulseaudio.patch
- "
-
-build() {
- autoreconf -vif
- mkdir -p build && cd build
- ../configure --prefix=/usr \
- --disable-pulseaudio
- make
-}
-
-package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="6dadff19e53499d169ba4f491e1f821014b4f92fc3c93d7947c85cbbbdeaba538d02bd8ab98fe266a8f80756a287fd5803ec77a8cd874d50082b5cad309875c2 i3status-2.13.tar.bz2
-759f8e8aba9e5b5b6d390935c440ecfab2a1aaffb92b9cc20aec80e8f0bce2f0b79119991aee349573daf55b421bc1f80a5dc69e554fd16ff7e0ddf69d24c39b no-pulseaudio.patch"
diff --git a/testing/i3status/no-pulseaudio.patch b/testing/i3status/no-pulseaudio.patch
deleted file mode 100644
index 863d2ad824..0000000000
--- a/testing/i3status/no-pulseaudio.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index a6c31d7..11caa33 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -80,11 +80,24 @@
- PKG_CHECK_MODULES([CONFUSE], [libconfuse])
- PKG_CHECK_MODULES([YAJL], [yajl])
-
-+AC_ARG_ENABLE(pulseaudio,
-+ AS_HELP_STRING(
-+ [--disable-pulseaudio],
-+ [build without pulseaudio support]),
-+ [ax_pulse=$enableval],
-+ [ax_pulse=yes])
-+AM_CONDITIONAL([PULSE], [test x$ax_pulse = xyes])
-+AS_IF([test x"$ax_pulse" = x"yes"],
-+ [PKG_CHECK_MODULES([PULSE], [libpulse])])
-+pulse_def=0
-+AS_IF([test x"$ax_pulse" = x"yes"],
-+ [pulse_def=1])
-+AC_DEFINE_UNQUOTED([HAS_PULSEAUDIO], [$pulse_def], [Build with pulseaudio])
-+
- case $host_os in
- linux*)
- PKG_CHECK_MODULES([NLGENL], [libnl-genl-3.0])
- PKG_CHECK_MODULES([ALSA], [alsa])
-- PKG_CHECK_MODULES([PULSE], [libpulse])
- ;;
- netbsd*)
- AC_SEARCH_LIBS([prop_string_create], [prop])
-@@ -151,6 +164,7 @@
- AS_HELP_STRING([enable debug flags:], [${ax_enable_debug}])
- AS_HELP_STRING([code coverage:], [${CODE_COVERAGE_ENABLED}])
- AS_HELP_STRING([enabled sanitizers:], [${ax_enabled_sanitizers}])
-+AS_HELP_STRING([pulseaudio support:], [${ax_pulse}])
-
- To compile, run:
-
-diff --git a/Makefile.am b/Makefile.am
-index bb251f0..c2c1c0a 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -68,8 +68,11 @@ i3status_SOURCES = \
- src/print_volume.c \
- src/print_wireless_info.c \
- src/print_file_contents.c \
-- src/process_runs.c \
-- src/pulse.c
-+ src/process_runs.c
-+
-+if PULSE
-+i3status_SOURCES += src/pulse.c
-+endif
-
- dist_sysconf_DATA = \
- i3status.conf
-diff --git a/i3status.c b/i3status.c
-index 0898da3..1ab8400 100644
---- a/i3status.c
-+++ b/i3status.c
-@@ -565,7 +565,13 @@ int main(int argc, char *argv[]) {
- return 0;
- break;
- case 'v':
-- printf("i3status " VERSION " © 2008 Michael Stapelberg and contributors\n");
-+ printf("i3status " VERSION " © 2008 Michael Stapelberg and contributors\n"
-+#if HAS_PULSEAUDIO
-+ "Built with pulseaudio support\n"
-+#else
-+ "Built without pulseaudio support\n"
-+#endif
-+ );
- return 0;
- break;
- case 0:
-diff --git a/src/print_volume.c b/src/print_volume.c
-index 91e8ce2..7364d47 100644
---- a/src/print_volume.c
-+++ b/src/print_volume.c
-@@ -86,7 +86,7 @@ void print_volume(yajl_gen json_gen, char *buffer, const char *fmt, const char *
- free(instance);
- }
-
--#if !defined(__DragonFly__) && !defined(__OpenBSD__)
-+#if HAS_PULSEAUDIO
- /* Try PulseAudio first */
-
- /* If the device name has the format "pulse[:N]" where N is the