aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-10 09:07:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-10 12:46:49 +0000
commit9ef72de4812339d34f1e4c5b189d813892484ecf (patch)
treea63debd4dafa0dfa83764bf9bdc1e7abd7852167 /testing
parentfcb175a506839b40c111af26ae5f99e9a313338a (diff)
downloadaports-9ef72de4812339d34f1e4c5b189d813892484ecf.tar.bz2
aports-9ef72de4812339d34f1e4c5b189d813892484ecf.tar.xz
main/ortp: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/ortp/APKBUILD47
-rw-r--r--testing/ortp/ortp-0.16.1-retval.patch20
-rw-r--r--testing/ortp/ortp-0.16.1-unusedvar.patch42
3 files changed, 0 insertions, 109 deletions
diff --git a/testing/ortp/APKBUILD b/testing/ortp/APKBUILD
deleted file mode 100644
index bc419952a4..0000000000
--- a/testing/ortp/APKBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=ortp
-pkgver=0.16.1
-pkgrel=0
-pkgdesc="A C library implementing the RTP protocol (RFC3550)"
-url="http://www.linphone.org/index.php/code_review/ortp"
-arch="all"
-license="LGPLv2+ VSL"
-depends=""
-makedepends=""
-install=""
-subpackages="$pkgname-dev"
-source="http://nongnu.askapache.com/linphone/ortp/sources/ortp-$pkgver.tar.gz
- ortp-0.16.1-retval.patch
- ortp-0.16.1-unusedvar.patch
- "
-
-_builddir="$srcdir"/ortp-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --disable-static \
- --enable-ipv6 \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-md5sums="bc96cdcb9c139d366a720a94200f92dd ortp-0.16.1.tar.gz
-cdd971e04073b3de2e935e6ff502110f ortp-0.16.1-retval.patch
-f3323a01f3d82279c3ce5ed1bb1969c5 ortp-0.16.1-unusedvar.patch"
diff --git a/testing/ortp/ortp-0.16.1-retval.patch b/testing/ortp/ortp-0.16.1-retval.patch
deleted file mode 100644
index 679f8d7d49..0000000000
--- a/testing/ortp/ortp-0.16.1-retval.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -up ortp-0.16.1/src/stun.c.retval ortp-0.16.1/src/stun.c
---- ortp-0.16.1/src/stun.c.retval 2010-09-04 10:14:53.000000000 +0200
-+++ ortp-0.16.1/src/stun.c 2010-09-04 10:15:10.000000000 +0200
-@@ -1191,6 +1191,7 @@ stunRand(void)
- int maxFd=0;
- struct timeval tv;
- int e;
-+ int res;
-
- int fd=open("/dev/random",O_RDONLY);
-
-@@ -1213,7 +1214,7 @@ stunRand(void)
- closesocket(fd);
- return random();
- }
-- read(fd,&tick,sizeof(tick));
-+ res = read(fd,&tick,sizeof(tick));
- closesocket(fd);
- }
- #else
diff --git a/testing/ortp/ortp-0.16.1-unusedvar.patch b/testing/ortp/ortp-0.16.1-unusedvar.patch
deleted file mode 100644
index 0e5d18c868..0000000000
--- a/testing/ortp/ortp-0.16.1-unusedvar.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -up ortp-0.16.1/src/stun.c.unusedvar ortp-0.16.1/src/stun.c
---- ortp-0.16.1/src/stun.c.unusedvar 2011-03-15 12:35:33.000000000 +0000
-+++ ortp-0.16.1/src/stun.c 2011-03-15 12:35:33.000000000 +0000
-@@ -1191,7 +1191,7 @@ stunRand(void)
- int maxFd=0;
- struct timeval tv;
- int e;
-- int res;
-+ __attribute__((__unused__)) int res;
-
- int fd=open("/dev/random",O_RDONLY);
-
-@@ -1985,7 +1985,7 @@ stunSendTest( Socket myFd, StunAddress4
-
- bool_t changePort=FALSE;
- bool_t changeIP=FALSE;
-- bool_t discard=FALSE;
-+ __attribute__((__unused__)) bool_t discard=FALSE;
-
- StunMessage req;
- char buf[STUN_MAX_MESSAGE_SIZE];
-@@ -2154,7 +2154,7 @@ stunNatType( StunAddress4 *dest,
-
- bool_t respTestI=FALSE;
- bool_t isNat=TRUE;
-- StunAddress4 testIchangedAddr;
-+ __attribute__((__unused__)) StunAddress4 testIchangedAddr;
- StunAddress4 testImappedAddr;
- bool_t respTestI2=FALSE;
- bool_t mappedIpSame = TRUE;
-diff -up ortp-0.16.1/src/tests/rtprecv.c.unusedvar ortp-0.16.1/src/tests/rtprecv.c
---- ortp-0.16.1/src/tests/rtprecv.c.unusedvar 2011-03-15 12:36:28.000000000 +0000
-+++ ortp-0.16.1/src/tests/rtprecv.c 2011-03-15 12:36:53.000000000 +0000
-@@ -162,7 +162,7 @@ int main(int argc, char*argv[])
- if (err>0) stream_received=1;
- /* this is to avoid to write to disk some silence before the first RTP packet is returned*/
- if ((stream_received) && (err>0)) {
-- size_t ret = fwrite(buffer,1,err,outfile);
-+ __attribute__((__unused__)) size_t ret = fwrite(buffer,1,err,outfile);
- if (sound_fd>0)
- ret = write(sound_fd,buffer,err);
- }