aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-30 17:09:33 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-10 20:55:47 +0000
commita24d99d9ad4519317a9cd600dd30550f6eb2df2a (patch)
tree49be8bbba714e5c46f5216bf50735c27c5da665c /testing
parent09691e886b47525fd4e3bc45f1f91de87ab3c22e (diff)
downloadaports-a24d99d9ad4519317a9cd600dd30550f6eb2df2a.tar.bz2
aports-a24d99d9ad4519317a9cd600dd30550f6eb2df2a.tar.xz
testing/libxmlb: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libxmlb/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/libxmlb/APKBUILD b/testing/libxmlb/APKBUILD
new file mode 100644
index 0000000000..6b249b8d8d
--- /dev/null
+++ b/testing/libxmlb/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=libxmlb
+pkgver=0.1.9
+pkgrel=0
+pkgdesc="Library to help create and query binary XML blobs"
+url="https://github.com/hughsie/libxmlb"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="meson glib-dev util-linux-dev gobject-introspection-dev"
+checkdepends="shared-mime-info"
+subpackages="$pkgname-dev:_dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hughsie/libxmlb/archive/$pkgver.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ -Dgtkdoc=false \
+ -Dtests=true \
+ -Dstemmer=false \
+ -Dintrospection=true \
+ build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+ rm -rf "$pkgdir"/usr/share/installed-tests
+}
+
+_dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/libexec "$subpkgdir"/usr
+}
+
+sha512sums="a87e3a708bf5a7dc5452da5a3157fe79224c32175add63f6c077252c856e58cdfb80d0d69a79868964abb318cc44d5512a61eb99c8267ff2fb9aa921ed78fb13 libxmlb-0.1.9.tar.gz"