aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2017-10-01 18:47:41 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-01-23 21:49:36 +0000
commita3509d779e928b0c8ceeec3b7b66da8d350019f7 (patch)
tree1e883e204b868c63fc9404a945a586c3fe47cd76 /testing
parent06025e4f37982dab183624e56061ea5ff1ae7db8 (diff)
downloadaports-a3509d779e928b0c8ceeec3b7b66da8d350019f7.tar.bz2
aports-a3509d779e928b0c8ceeec3b7b66da8d350019f7.tar.xz
testing/fzf: add package
Diffstat (limited to 'testing')
-rw-r--r--testing/fzf/APKBUILD52
-rw-r--r--testing/fzf/no-glide-install.patch11
2 files changed, 63 insertions, 0 deletions
diff --git a/testing/fzf/APKBUILD b/testing/fzf/APKBUILD
new file mode 100644
index 0000000000..39ec7beb9e
--- /dev/null
+++ b/testing/fzf/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Kevin Daudt <ops@ikke.info>
+# Maintainer: Kevin Daudt <ops@ikke.info>
+pkgname=fzf
+pkgver="0.17.0.2"
+_pkgver="${pkgver%.*}-${pkgver##*.}"
+pkgrel=0
+pkgdesc="A command-line fuzzy finder"
+url="https://github.com/junegunn/fzf"
+arch="all"
+license="MIT"
+makedepends="go glide bash tmux"
+subpackages="$pkgname-tmux::noarch"
+source="$pkgname-$_pkgver.tar.gz::https://github.com/junegunn/fzf/archive/$_pkgver.tar.gz
+ no-glide-install.patch"
+builddir="$srcdir/$pkgname-$_pkgver"
+
+prepare() {
+ default_prepare
+
+ export GOPATH="$startdir"
+ glide install
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+
+ # Just copies the target binary to $buildir/bin
+ make install
+
+ install -Dm0755 bin/fzf "$pkgdir"/usr/bin/fzf
+}
+
+tmux() {
+ depends="tmux bash"
+ description="Helper script to start fzf in a tmux pane"
+
+ cd "$builddir"
+ install -Dm0755 bin/fzf-tmux "$subpkgdir"/usr/bin/fzf-tmux
+}
+
+sha512sums="94695831b5c2460f516c982bcd006b4e380509dc77ca9d8785424029f1a5fc25c1150b91c0add6804fcc48d7880a63b94b81b63e56ce817a4837bb659884676e fzf-0.17.0-2.tar.gz
+daa16985079e3b55ccf5e74dde356e1e13e43865c9809e432b5d272b053f541f1eacd402f3b04957ee855fb8c0ca1820b507d08e408f55dc80004990a949874c no-glide-install.patch"
diff --git a/testing/fzf/no-glide-install.patch b/testing/fzf/no-glide-install.patch
new file mode 100644
index 0000000000..1704ee9e22
--- /dev/null
+++ b/testing/fzf/no-glide-install.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -99,7 +99,7 @@
+ ln -sf $(ROOT_DIR)/vendor $(VENDOR_LINK)
+
+ vendor: $(GLIDE_YAML)
+- go get -u github.com/Masterminds/glide && $(GOPATH)/bin/glide install && touch $@
++ touch $@
+
+ test: $(SOURCES) vendor
+ SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" \