aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-02 00:01:33 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-10 19:39:08 +0000
commitb995ba418f12a756881f6f9228c326dd7fc00a57 (patch)
tree6300a06c1d3a499d926e1820364023b6b4f63303 /testing
parent92c782fd4c76fa0f9391889b9443789e293e672b (diff)
downloadaports-b995ba418f12a756881f6f9228c326dd7fc00a57.tar.bz2
aports-b995ba418f12a756881f6f9228c326dd7fc00a57.tar.xz
testing/uchardet: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/uchardet/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/uchardet/APKBUILD b/testing/uchardet/APKBUILD
new file mode 100644
index 0000000000..f8ab9b6d3e
--- /dev/null
+++ b/testing/uchardet/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=uchardet
+pkgver=0.0.6
+pkgrel=0
+pkgdesc="Encoding detector library ported from Mozilla"
+url="https://www.freedesktop.org/wiki/Software/uchardet"
+arch="all"
+license="MPL-1.1"
+makedepends="cmake"
+options="!check" # fail on x86, upstream is dead
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.freedesktop.org/software/uchardet/releases/uchardet-${pkgver}.tar.xz"
+builddir="$srcdir/uchardet-$pkgver"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ # overwrite failing test
+ touch test/th/utf-8.txt test/th/tis-620.txt
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="eceeadae060bf277e298d709856609dde32921271140dc1fb0a33c7b6e1381033fc2960d616ebbd82c92815936864d2c0743b1b5ea1b7d4a200df87df80d6de5 uchardet-0.0.6.tar.xz"