aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-16 13:43:15 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-16 11:39:21 -0300
commitc564454e11ad4d59f9da0d07680a57eedee7d946 (patch)
treeed2487d97771357cd8a2a03ca405a50c9883fbfe /testing
parent575a459cbab3f7afe7847fa301e6ab5341a59926 (diff)
downloadaports-c564454e11ad4d59f9da0d07680a57eedee7d946.tar.bz2
aports-c564454e11ad4d59f9da0d07680a57eedee7d946.tar.xz
testing/plymouth-kcm: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/plymouth-kcm/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/plymouth-kcm/APKBUILD b/testing/plymouth-kcm/APKBUILD
new file mode 100644
index 0000000000..86ea46b598
--- /dev/null
+++ b/testing/plymouth-kcm/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plymouth-kcm
+pkgver=5.16.5
+pkgrel=0
+arch="all"
+url="https://cgit.kde.org/plymouth-kcm.git"
+pkgdesc="KCM to manage the Plymouth (Boot) theme"
+license="GPL-2.0-or-later"
+depends="plymouth"
+makedepends="extra-cmake-modules qt5-qtbase-dev karchive-dev knewstuff-dev kio-dev kdeclarative-dev ki18n-dev kconfig-dev kconfigwidgets-dev plymouth-dev kcmutils"
+source="https://download.kde.org/stable/plasma/$pkgver/plymouth-kcm-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="9544cd44cddb5736b38be649e61bf0ed0c7553ac0fa8e7de978e297cfa3d0046339832937ee8ca2e83f610b5516b90c512ebaeb20a9c66c7ea47fb93c1d3fd36 plymouth-kcm-5.16.5.tar.xz"