aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2018-02-09 23:24:11 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-13 14:29:02 +0000
commitd131db6d9d084e11911b6899b9429a17345706a2 (patch)
tree441c4a52e0a1c4b8e2dfcbc19ab5bafaf437f233 /testing
parent934d43aaca5b4dbd2ed14c5a94485a6639ddbd18 (diff)
downloadaports-d131db6d9d084e11911b6899b9429a17345706a2.tar.bz2
aports-d131db6d9d084e11911b6899b9429a17345706a2.tar.xz
testing/[various]: fix supported archs
these packages only support these ports atm geos : test fails on all arch except x86*
Diffstat (limited to 'testing')
-rw-r--r--testing/fzf/APKBUILD2
-rw-r--r--testing/geos/APKBUILD3
-rw-r--r--testing/litespeed/APKBUILD2
-rw-r--r--testing/reptyr/APKBUILD2
4 files changed, 5 insertions, 4 deletions
diff --git a/testing/fzf/APKBUILD b/testing/fzf/APKBUILD
index 124757fc26..3f4b2dc00f 100644
--- a/testing/fzf/APKBUILD
+++ b/testing/fzf/APKBUILD
@@ -6,7 +6,7 @@ _pkgver="${pkgver%.*}-${pkgver##*.}"
pkgrel=0
pkgdesc="A command-line fuzzy finder"
url="https://github.com/junegunn/fzf"
-arch="all !ppc64le !aarch64 !armhf"
+arch="x86 x86_64"
license="MIT"
makedepends="go glide bash tmux"
subpackages="$pkgname-tmux::noarch"
diff --git a/testing/geos/APKBUILD b/testing/geos/APKBUILD
index 3530d2cb11..50c9255a8c 100644
--- a/testing/geos/APKBUILD
+++ b/testing/geos/APKBUILD
@@ -5,7 +5,8 @@ pkgver=3.6.2
pkgrel=0
pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
url="http://trac.osgeo.org/geos/"
-arch="all !armhf !aarch64 !ppc64le" # !*: tests fail
+# test fails on other archs
+arch="x86 x86_64"
license="LGPL-2.1"
makedepends="swig python2-dev"
subpackages="py-$pkgname:py $pkgname-dev"
diff --git a/testing/litespeed/APKBUILD b/testing/litespeed/APKBUILD
index 4238a7b0be..ed43500781 100644
--- a/testing/litespeed/APKBUILD
+++ b/testing/litespeed/APKBUILD
@@ -8,7 +8,7 @@ _pkghome=var/lib/$pkgname
_php=php7
pkgdesc="High-performance, lightweight, open source HTTP server"
url="https://open.litespeedtech.com"
-arch="all !aarch64 !ppc64le"
+arch="x86 x86_64 armhf"
license="GPL-3.0"
pkgusers=litespeed
pkggroups=litespeed
diff --git a/testing/reptyr/APKBUILD b/testing/reptyr/APKBUILD
index 85ac89dc23..60dba0dcd6 100644
--- a/testing/reptyr/APKBUILD
+++ b/testing/reptyr/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.6.2
pkgrel=0
pkgdesc="Reparent a running program to a new terminal"
url="https://github.com/nelhage/reptyr"
-arch="all !aarch64 !ppc64le"
+arch="x86 x86_64 armhf"
license="MIT"
makedepends="linux-headers"
subpackages="$pkgname-doc"