aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-16 21:07:07 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-16 21:07:07 +0000
commit0fe60c188661d9a159d050757eb36f250ed70537 (patch)
tree7451686a3cca2d28c53f772b985b693cdd887570 /testing
parentddac91667ef56e02bcc6c61cac3d4979c62e08c8 (diff)
downloadaports-0fe60c188661d9a159d050757eb36f250ed70537.tar.bz2
aports-0fe60c188661d9a159d050757eb36f250ed70537.tar.xz
testing/dep: move to community
Diffstat (limited to 'testing')
-rw-r--r--testing/dep/APKBUILD38
1 files changed, 0 insertions, 38 deletions
diff --git a/testing/dep/APKBUILD b/testing/dep/APKBUILD
deleted file mode 100644
index eb6f81e564..0000000000
--- a/testing/dep/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Ed Robinson <edward-robinson@cookpad.com>
-# Maintainer: Ed Robinson <edward-robinson@cookpad.com>
-pkgname=dep
-pkgver=0.4.1
-pkgrel=0
-pkgdesc="Go dependency management tool"
-url="https://github.com/golang/dep"
-arch="all"
-license="BSD-3-Clause"
-makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/golang/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-builddir="$srcdir/src/github.com/golang/$pkgname"
-
-prepare() {
- mkdir -p ${builddir%/*}
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
- default_prepare
-}
-
-build() {
- export GOPATH="$srcdir"
- cd "$builddir"
- go build -ldflags="-X main.version=$pkgver" -o ./bin/dep ./cmd/dep
-}
-
-package() {
- cd "$builddir"
- install -Dm755 ./bin/dep "$pkgdir"/usr/bin/dep
-}
-
-check() {
- cd "$builddir"
- ./bin/dep status > /dev/null
-}
-
-sha512sums="29caef5dbbb21020f4ba4024b9c8601da5c7f9f8caa5ab63c6dfa927be2140d33037473600246f35a6e58f94bad592b1974c38b8b9fec6f4d1d68ec8324db3d2 dep-0.4.1.tar.gz"