aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 11:31:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 11:35:25 -0300
commit33cd2f2e27d236ab095e18ff441c41c061c74e9e (patch)
tree234a895130b5bf7cc3c4b51dc1aace487cca4cdf /testing
parent35b1ddc6c91b9c0bbab4bf5296b854524547c781 (diff)
downloadaports-33cd2f2e27d236ab095e18ff441c41c061c74e9e.tar.bz2
aports-33cd2f2e27d236ab095e18ff441c41c061c74e9e.tar.xz
testing/py3-chameleon: drop py2
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-chameleon/APKBUILD44
1 files changed, 10 insertions, 34 deletions
diff --git a/testing/py3-chameleon/APKBUILD b/testing/py3-chameleon/APKBUILD
index 944743437e..611430b540 100644
--- a/testing/py3-chameleon/APKBUILD
+++ b/testing/py3-chameleon/APKBUILD
@@ -1,53 +1,29 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-chameleon
-_pkgname=Chameleon
+pkgname=py3-chameleon
pkgver=3.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="A Fast Python HTML/XML Template Compiler"
url="https://chameleon.readthedocs.org"
arch="noarch"
license="BSD-3-Clause AND BSD-4-Clause AND Python-2.0 AND ZPL-2.1"
-depends="py-setuptools"
-makedepends="py2-setuptools py3-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+depends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/malthe/chameleon/archive/$pkgver.tar.gz"
+builddir="$srcdir"/chameleon-$pkgver
+
+replaces="py-chameleon" # Backwards compatibility
+provides="py-chameleon=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python2 setup.py build
python3 setup.py build
}
-
check() {
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0bdc1314cbb37f462de640b89f0e7319025938253df34303c033c8cc903f94f183bb33fc99afdda9ff4cf500c78778df6f5f1f72c0c1607014d6a38117d269e4 Chameleon-3.6.2.tar.gz"
+sha512sums="887d7b31b14ee18f31fe5f5405914e0137e507f7f936763ee1a2ed09d887416d9399db50dc9a9d2137f6815cbe9dfec8729918264601b09faa5fb4ebf9b855df py3-chameleon-3.6.2.tar.gz"