aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-07-25 13:39:51 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-07-25 13:39:51 +0000
commit388752fa23fb4c776fbbb2a0ad7b04d16c336b4c (patch)
tree297d754fbe98e595a46a89c1521336f08bec3bc0 /testing
parent2817dcbd8611bec09cd7436771fc4d248ddfc732 (diff)
parent694f922569d04fef76eb881f5a660df8342e30f5 (diff)
downloadaports-388752fa23fb4c776fbbb2a0ad7b04d16c336b4c.tar.bz2
aports-388752fa23fb4c776fbbb2a0ad7b04d16c336b4c.tar.xz
Merge git://dev.alpinelinux.org/aports
Diffstat (limited to 'testing')
-rw-r--r--testing/evas/APKBUILD2
-rw-r--r--testing/fotoxx/APKBUILD11
-rw-r--r--testing/fotoxx/no-execinfo.patch34
-rw-r--r--testing/fotoxx/no-xdg-desktop-menu.patch10
-rw-r--r--testing/openjpeg/APKBUILD2
-rw-r--r--testing/podofo/APKBUILD2
-rw-r--r--testing/rxvt-unicode/APKBUILD4
7 files changed, 20 insertions, 45 deletions
diff --git a/testing/evas/APKBUILD b/testing/evas/APKBUILD
index d200b6c52e..7f0dc9d1a2 100644
--- a/testing/evas/APKBUILD
+++ b/testing/evas/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=evas
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="hardware-accelerated retained canvas API"
url="http://trac.enlightenment.org/e/wiki/Evas"
arch="all"
diff --git a/testing/fotoxx/APKBUILD b/testing/fotoxx/APKBUILD
index 0edb118536..d327ae72ff 100644
--- a/testing/fotoxx/APKBUILD
+++ b/testing/fotoxx/APKBUILD
@@ -1,18 +1,18 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fotoxx
-pkgver=11.06
+pkgver=12.07.1
pkgrel=0
pkgdesc="Photo editing and collection management"
url="http://kornelix.squarespace.com/fotoxx"
arch="all"
license="GPL-3"
depends="xdg-utils exiftool"
-makedepends="gtk+-dev tiff-dev"
+makedepends="gtk+3.0-dev tiff-dev"
install=
subpackages="$pkgname-doc"
source="http://kornelix.squarespace.com/storage/downloads/fotoxx-$pkgver.tar.gz
- no-execinfo.patch"
+ no-xdg-desktop-menu.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -23,7 +23,6 @@ prepare() {
*.patch) patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
- sed -e 's:/bin/bash:/bin/sh:' -i dependencies.sh
}
build() {
@@ -36,5 +35,5 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
}
-md5sums="e636e10f6a46f0a813e704f18eac3176 fotoxx-11.06.tar.gz
-981323960d1316051b898ba194085205 no-execinfo.patch"
+md5sums="56022f26a3db1fdc62024027fe73901e fotoxx-12.07.1.tar.gz
+8c988a8ced48cfe3a5a49be4a705b045 no-xdg-desktop-menu.patch"
diff --git a/testing/fotoxx/no-execinfo.patch b/testing/fotoxx/no-execinfo.patch
deleted file mode 100644
index c0e43a9f7c..0000000000
--- a/testing/fotoxx/no-execinfo.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/zfuncs.cc b/zfuncs.cc
-index 1398557..c504bbf 100644
---- a/zfuncs.cc
-+++ b/zfuncs.cc
-@@ -77,6 +77,7 @@ void zappcrash(cchar *pMess, ... ) // v
-
- printf("zappcrash: \n %s \n",message); // output message to stdout
-
-+#ifndef __UCLIBC__
- nstack = backtrace(stacklist,nstack); // get traceback data
- stackents = backtrace_symbols(stacklist,nstack);
-
-@@ -113,6 +114,7 @@ void zappcrash(cchar *pMess, ... ) // v
- fclose(fid1);
-
- err = system("xdg-open zappcrash"); // display in editor
-+#endif
- abort();
- }
-
-diff --git a/zfuncs.h b/zfuncs.h
-index e415adb..b6f02ac 100644
---- a/zfuncs.h
-+++ b/zfuncs.h
-@@ -34,7 +34,9 @@
- #include <pthread.h>
- #include <errno.h>
- #include <signal.h>
-+#ifndef __UCLIBC__
- #include <execinfo.h>
-+#endif
- #include <locale.h>
- #include <sys/inotify.h>
-
diff --git a/testing/fotoxx/no-xdg-desktop-menu.patch b/testing/fotoxx/no-xdg-desktop-menu.patch
new file mode 100644
index 0000000000..0e2813fb81
--- /dev/null
+++ b/testing/fotoxx/no-xdg-desktop-menu.patch
@@ -0,0 +1,10 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -76,7 +76,6 @@
+ rm -f fotoxx.1.gz
+ # menu (desktop) file
+ cp -f desktop $(DESTDIR)$(MENUFILE)
+- xdg-desktop-menu install $(DESTDIR)$(MENUFILE)
+
+ uninstall:
+ rm -f $(DESTDIR)$(BINDIR)/fotoxx
diff --git a/testing/openjpeg/APKBUILD b/testing/openjpeg/APKBUILD
index d2e3912bbd..dda2a4102a 100644
--- a/testing/openjpeg/APKBUILD
+++ b/testing/openjpeg/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=openjpeg
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Open-source implementation of JPEG2000 image codec"
url="http://www.openjpeg.org/"
arch="all"
diff --git a/testing/podofo/APKBUILD b/testing/podofo/APKBUILD
index 1b413ebf1a..e7b12d1c25 100644
--- a/testing/podofo/APKBUILD
+++ b/testing/podofo/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=podofo
pkgver=0.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="A C++ library to work with the PDF file format"
url="http://podofo.sourceforge.net"
arch="all"
diff --git a/testing/rxvt-unicode/APKBUILD b/testing/rxvt-unicode/APKBUILD
index f4a03602cf..2f67a0d616 100644
--- a/testing/rxvt-unicode/APKBUILD
+++ b/testing/rxvt-unicode/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Moritz Wilhelmy
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rxvt-unicode
-pkgver=9.11
+pkgver=9.15
pkgrel=0
pkgdesc='rxvt fork with improved unicode support'
arch=all
@@ -39,4 +39,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="1bed5bfeed026e0bfafa0e9e4f62aa37 rxvt-unicode-9.11.tar.bz2"
+md5sums="15595aa326167ac5eb68c28d95432faf rxvt-unicode-9.15.tar.bz2"