aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-20 13:28:45 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-21 10:31:47 +0000
commit3e349e0670ed3255aa6f2c249722ab0df13bda78 (patch)
treec868e94e2782b0db74f0cd436e9d2ff9b423874d /testing
parent6655e574d6e88a7703ab040909b02c3e83721969 (diff)
downloadaports-3e349e0670ed3255aa6f2c249722ab0df13bda78.tar.bz2
aports-3e349e0670ed3255aa6f2c249722ab0df13bda78.tar.xz
testing/py-pycryptodome: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py-pycryptodome/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-pycryptodome/APKBUILD b/testing/py-pycryptodome/APKBUILD
new file mode 100644
index 0000000000..028394b9fc
--- /dev/null
+++ b/testing/py-pycryptodome/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-pycryptodome
+pkgver=3.4.6
+pkgrel=0
+pkgdesc="Self-contained cryptographic library"
+url="https://github.com/coveralls-clients/coveralls-python"
+arch="all"
+license="Apache2"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+options="!check" #no testsuite
+source="$pkgname-$pkgver.tar.gz::https://github.com/Legrandin/pycryptodome/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/pycryptodome-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="40c9ea4cf7fca06bd7cd3a100e1d602e0130fbdcc75544ff1353ced2fae8925d29286200561832f2524a0f3db155a6924bb653d964408d4486aab694bf275cdc py-pycryptodome-3.4.6.tar.gz"