aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-26 02:26:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-26 02:26:30 -0300
commit3f7afadd0b1db2615d4aff1f9dd9065bd05c56a7 (patch)
tree39299c7d2da39529d47c498c330ad1b3b15c0651 /testing
parent33fb8e5b946e07d2a607d8dfcbd04f6824e3988d (diff)
downloadaports-3f7afadd0b1db2615d4aff1f9dd9065bd05c56a7.tar.bz2
aports-3f7afadd0b1db2615d4aff1f9dd9065bd05c56a7.tar.xz
testing/py3-gitlab: new aport
https://github.com/python-gitlab/python-gitlab v4 GitLab API compliant library and cmdline tool
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-gitlab/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-gitlab/APKBUILD b/testing/py3-gitlab/APKBUILD
new file mode 100644
index 0000000000..e645c727b8
--- /dev/null
+++ b/testing/py3-gitlab/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-gitlab
+_pkgname=python-gitlab
+pkgver=1.11.0
+pkgrel=0
+pkgdesc="v4 GitLab API compliant library and cmdline tool"
+options="!check" # Requires unpackaged 'httmock'
+url="https://github.com/python-gitlab/python-gitlab"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="python3 py3-requests py3-six"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-mock"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ py.test-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="26af77485eed5212bbe581adb7be6dd85f824de258a0775c6946a5c0adf5c4bacdb2edbcdb3501408fb1019f07b8995cd13dfb65fa742582e26e4d7afddf5a9d python-gitlab-1.11.0.tar.gz"